summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2021-03-27 14:43:46 +0000
committerDaniel Bermond2021-03-27 14:43:46 +0000
commit4095fa40dd03baf2369dffcdc66c7ce7d8f2bcc4 (patch)
tree9abc63f09e2cc7aa4348545d4bae28c0cf5fd4c1
parent9cd668c71e64312d924bc9190f5913e6b9c86823 (diff)
downloadaur-4095fa40dd03baf2369dffcdc66c7ce7d8f2bcc4.tar.gz
Update to version 5.11.10
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0cae125b871..ace584c1cd51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
pkgbase = mips64el-linux-gnu-linux-api-headers
- pkgdesc = Kernel headers sanitized for use in userspace (mips64el-linux-gnu)
- pkgver = 5.2.6
+ pkgdesc = Kernel headers sanitized for use in userspace (MIPS64EL target, for the toolchain with GNU C library and multilib ABI)
+ pkgver = 5.11.10
pkgrel = 1
- url = http://www.kernel.org
+ url = https://www.kernel.org
arch = any
license = GPL2
- source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.2.6.tar.xz
- sha1sums = b07b8b7997a7211c25f5b51341890d4f2c349646
+ makedepends = rsync
+ source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.11.10.tar.xz
+ source = http://www.kernel.org/pub/linux/kernel/v5.x/linux-5.11.10.tar.sign
+ validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
+ validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
+ sha256sums = d372acb8fa337141ca1bbeda9e25873c76ce52a27974226a95275ce43522dc1d
+ sha256sums = SKIP
pkgname = mips64el-linux-gnu-linux-api-headers
diff --git a/PKGBUILD b/PKGBUILD
index 5a95a4d96307..095d41cc0bce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: Wu Xiaotian <yetist@gmail.com>
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
+# Contributor: Wu Xiaotian <yetist@gmail.com>
_target_arch=mips
_target=mips64el-linux-gnu
-pkgname=$_target-linux-api-headers
-pkgver=5.2.6
+pkgname="${_target}-linux-api-headers"
+pkgver=5.11.10
pkgrel=1
-pkgdesc="Kernel headers sanitized for use in userspace ($_target)"
-arch=(any)
-url='http://www.kernel.org'
-license=(GPL2)
-source=(http://www.kernel.org/pub/linux/kernel/v5.x/linux-$pkgver.tar.xz)
-sha1sums=('b07b8b7997a7211c25f5b51341890d4f2c349646')
+pkgdesc='Kernel headers sanitized for use in userspace (MIPS64EL target, for the toolchain with GNU C library and multilib ABI)'
+arch=('any')
+url='https://www.kernel.org'
+license=('GPL2')
+makedepends=('rsync')
+source=("http://www.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/linux-${pkgver}.tar".{xz,sign})
+sha256sums=('d372acb8fa337141ca1bbeda9e25873c76ce52a27974226a95275ce43522dc1d'
+ 'SKIP')
+validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
+ '647F28654894E3BD457199BE38DBBDC86092693E') # Greg Kroah-Hartman
build() {
- cd linux-$pkgver
-
- make ARCH=$_target_arch mrproper
- make ARCH=$_target_arch headers_check
+ make -C "linux-${pkgver}" ARCH="$_target_arch" mrproper headers_check
}
package() {
- cd linux-$pkgver
-
- make INSTALL_HDR_PATH="$pkgdir/usr/$_target/" ARCH=$_target_arch V=0 headers_install
-
- # clean-up unnecessary files generated during install
- find "$pkgdir" \( -name .install -or -name ..install.cmd \) -delete
+ make -C "linux-${pkgver}" INSTALL_HDR_PATH="${pkgdir}/usr/${_target}/" ARCH="${_target_arch}" headers_install
}