summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-09 21:30:29 -0400
committerXiao-Long Chen2015-06-09 21:30:29 -0400
commit8381f473338f1ea55ad352e34b1db577086509c4 (patch)
tree620ad728d4ca905fc5f1152a5559c19d84466ae2
parentd804538508bd3d7e360cba11f3180620b61e73e0 (diff)
downloadaur-8381f473338f1ea55ad352e34b1db577086509c4.tar.gz
Update to 0.13.2+15.10.20150605
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Build-fixes.patch38
-rw-r--r--PKGBUILD10
3 files changed, 43 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38b7a9deb691..5f1b4b68d4ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by makepkg 4.2.0
-# Thu Jan 1 21:54:49 UTC 2015
pkgbase = mir
pkgdesc = Ubuntu's new display server
- pkgver = 0.9.0+15.04.20141125
+ pkgver = 0.13.2+15.10.20150605
pkgrel = 1
url = https://launchpad.net/mir
arch = i686
@@ -26,11 +24,10 @@ pkgbase = mir
depends = glm
depends = mesa-libgl
depends = mesa
- depends = libdrm
- source = https://launchpad.net/ubuntu/+archive/primary/+files/mir_0.9.0+15.04.20141125.orig.tar.gz
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/mir_0.13.2+15.10.20150605.orig.tar.gz
source = 0001-Build-fixes.patch
- sha512sums = 9ffb51f2acc6749652b6e20631337e82b4a2fac653e7a83a652834550f8ad94552d1663df72c0fb4fbe032abe0cd72b8a44faedacc2587e566494f7a75b6e8e8
- sha512sums = 46e2dad6390efeb96370b29be2a7ad85ff4234c0ca926337db25cbc2e0e0f395d8d656decd1d60289b321f2774b87e30095edb5d8ed35e45aa7b07187b35beb6
+ sha512sums = 440db939bf53224b52fddfd254c76ff259908aefb56d7e7571f8fcc6d6705be4d2c39d560c267cc131a00ccb22ec091897b998280b9f8294561ce334653193c7
+ sha512sums = 8e10a13a9d55ece03e0ed88fdaa84beb3e04d28ac8b2f05ba6c9518a5c24974059b8a35b6cc8fcf1b2be0fdc2e610b18db774c76d21950d86fd44f8950c4fecf
pkgname = mir
diff --git a/0001-Build-fixes.patch b/0001-Build-fixes.patch
index c1463ac4c687..1a6b5bf1f654 100644
--- a/0001-Build-fixes.patch
+++ b/0001-Build-fixes.patch
@@ -1,12 +1,29 @@
-From 58b8ada9009abd7b16962ca5631a7aa62d5ce5d9 Mon Sep 17 00:00:00 2001
+From 5c3a6130e7f64cfd64acd701e49cdb76e261ff1d Mon Sep 17 00:00:00 2001
From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
Date: Thu, 1 Jan 2015 00:33:56 -0500
Subject: [PATCH] Build fixes
---
- examples/glog_logger.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ CMakeLists.txt | 4 ++--
+ examples/glog_logger.cpp | 2 +-
+ src/platforms/mesa/server/cursor.cpp | 2 +-
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 130fe58..517bea3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -58,8 +58,8 @@ set(CMAKE_BUILD_TYPE ${CMAKE_BUILD_TYPE} CACHE STRING "${build_types}" FORCE)
+ # Enable cmake-gui to display a drop down list for CMAKE_BUILD_TYPE
+ set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "${build_types}")
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread -g -Werror -Wall -pedantic -Wextra -fPIC")
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread -g -std=c++14 -Werror -Wall -fno-strict-aliasing -pedantic -Wnon-virtual-dtor -Wextra -fPIC")
++set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread -g -Wall -pedantic -Wextra -fPIC")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread -g -std=c++14 -Wall -fno-strict-aliasing -pedantic -Wnon-virtual-dtor -Wextra -fPIC")
+
+ if ("${CMAKE_CXX_COMPILER}" MATCHES "clang")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-return-type-c-linkage -Wno-mismatched-tags")
diff --git a/examples/glog_logger.cpp b/examples/glog_logger.cpp
index 24f2ec4..58616bc 100644
--- a/examples/glog_logger.cpp
@@ -20,6 +37,19 @@ index 24f2ec4..58616bc 100644
}
} google_gflag_guard;
}
+diff --git a/src/platforms/mesa/server/cursor.cpp b/src/platforms/mesa/server/cursor.cpp
+index fee0ef7..6c18481 100644
+--- a/src/platforms/mesa/server/cursor.cpp
++++ b/src/platforms/mesa/server/cursor.cpp
+@@ -25,7 +25,7 @@
+ #include "mir/graphics/cursor_image.h"
+
+ #include <xf86drm.h>
+-#include <drm/drm.h>
++#include <libdrm/drm.h>
+
+ #include <boost/exception/errinfo_errno.hpp>
+
--
-2.2.1
+2.4.2
diff --git a/PKGBUILD b/PKGBUILD
index 437abe8a3a37..3d61d6fbc58f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@ desktop_arch=(i686 x86_64)
mobile_arch=()
pkgname=mir
-_actual_ver=0.9.0
-_extra_ver=+15.04.20141125
+_actual_ver=0.13.2
+_extra_ver=+15.10.20150605
pkgver=${_actual_ver}${_extra_ver}
pkgrel=1
pkgdesc="Ubuntu's new display server"
@@ -21,7 +21,7 @@ depends+=(glm mesa-libgl mesa)
if in_array "${CARCH}" "${desktop_arch[@]}"; then
depends+=(libdrm)
-elif in_array "${CARCH}" "${desktop_arch[@]}"; then
+elif in_array "${CARCH}" "${mobile_arch[@]}"; then
# Currently unpackaged. Presumably, Ubuntu's fork will need to be used
depends+=(libhybris)
fi
@@ -30,8 +30,8 @@ makedepends=(cmake30 doxygen graphviz libxslt umockdev)
source=("https://launchpad.net/ubuntu/+archive/primary/+files/mir_${_actual_ver}${_extra_ver}.orig.tar.gz"
0001-Build-fixes.patch)
-sha512sums=('9ffb51f2acc6749652b6e20631337e82b4a2fac653e7a83a652834550f8ad94552d1663df72c0fb4fbe032abe0cd72b8a44faedacc2587e566494f7a75b6e8e8'
- '46e2dad6390efeb96370b29be2a7ad85ff4234c0ca926337db25cbc2e0e0f395d8d656decd1d60289b321f2774b87e30095edb5d8ed35e45aa7b07187b35beb6')
+sha512sums=('440db939bf53224b52fddfd254c76ff259908aefb56d7e7571f8fcc6d6705be4d2c39d560c267cc131a00ccb22ec091897b998280b9f8294561ce334653193c7'
+ '8e10a13a9d55ece03e0ed88fdaa84beb3e04d28ac8b2f05ba6c9518a5c24974059b8a35b6cc8fcf1b2be0fdc2e610b18db774c76d21950d86fd44f8950c4fecf')
prepare() {
cd "mir-${_actual_ver}${_extra_ver}"