summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArifRoktim2017-04-02 17:27:13 -0400
committerArifRoktim2017-04-02 17:27:13 -0400
commit7c07e14d49d65b4ca179af1530a3cad2fe4e461c (patch)
treec28f3b7bcdb87f406e335211a383d9417ff1446e
downloadaur-7c07e14d49d65b4ca179af1530a3cad2fe4e461c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dc12a09eaa8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mir.qualia
+ pkgdesc = Automatically comment and uncomment config file sections
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/darkfeline/mir.qualia
+ arch = any
+ license = Apache
+ depends = python
+ depends = python-setuptools
+ source = https://github.com/darkfeline/mir.qualia/archive/v1.0.0.tar.gz
+ md5sums = 84943e0cb444d197c135504a33bca4df
+
+pkgname = mir.qualia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ef91b59f9ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Arif Roktim <arifrroktim at gmail dot com>
+pkgname=mir.qualia
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Automatically comment and uncomment config file sections"
+arch=('any')
+url="https://github.com/darkfeline/mir.qualia"
+license=('Apache')
+depends=('python' 'python-setuptools')
+makedepends=()
+source=('https://github.com/darkfeline/mir.qualia/archive/v1.0.0.tar.gz')
+md5sums=('84943e0cb444d197c135504a33bca4df')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python3 setup.py build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ python3 setup.py check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python3 setup.py install --single-version-externally-managed --optimize 01 --root="$pkgdir/" --prefix=/usr
+
+}