summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2022-05-08 21:47:43 -0400
committerChris Severance2022-05-08 21:47:43 -0400
commit9e56fdb4d8397a0111c2a9e40a97c584b47656d4 (patch)
tree9d3476d732b1f71456865b716a31d09b22f8f777
downloadaur-9e56fdb4d8397a0111c2a9e40a97c584b47656d4.tar.gz
Initial Import
-rw-r--r--.SRCINFO16
-rw-r--r--0000-mirth-connector-enable-DH768.patch16
-rw-r--r--PKGBUILD125
3 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..891138658e71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mirth-connect-administrator-launcher
+ pkgdesc = hl7 connector by Nextgen client
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://www.nextgen.com/products-and-services/integration-engine
+ arch = x86_64
+ license = MPL
+ depends = glibc
+ source = https://s3.amazonaws.com/downloads.mirthcorp.com/connect-client-launcher/mirth-administrator-launcher-1.2.0-unix.tar.gz
+ source = 0000-mirth-connector-enable-DH768.patch
+ md5sums = 3069335f10cc1d080cef7216cfb83401
+ md5sums = 34263d26eda5b5899969224bd3df1815
+ sha256sums = 63af212c5a95ab40eebf9249a214d89d23591e74d6e92ddcdfd42e5474d24d08
+ sha256sums = 45c43153a3841bdba9a0a3e9ee7883f54daaec18a3558434912656bc02688ca9
+
+pkgname = mirth-connect-administrator-launcher
diff --git a/0000-mirth-connector-enable-DH768.patch b/0000-mirth-connector-enable-DH768.patch
new file mode 100644
index 000000000000..19fc170e6134
--- /dev/null
+++ b/0000-mirth-connector-enable-DH768.patch
@@ -0,0 +1,16 @@
+diff -pNaru5 a/jre/lib/security/java.security b/jre/lib/security/java.security
+--- a/jre/lib/security/java.security 2021-04-14 18:50:45.000000000 -0400
++++ b/jre/lib/security/java.security 2022-02-11 17:16:44.159260698 -0500
+@@ -639,11 +639,11 @@ jdk.jar.disabledAlgorithms=MD2, MD5, RSA
+ # Note: This property is currently used by the JDK Reference implementation.
+ # It is not guaranteed to be examined and used by other implementations.
+ #
+ # Example:
+ # jdk.tls.disabledAlgorithms=MD5, SSLv3, DSA, RSA keySize < 2048
+-jdk.tls.disabledAlgorithms=SSLv3, RC4, MD5withRSA, DH keySize < 1024, \
++jdk.tls.disabledAlgorithms=SSLv3, RC4, MD5withRSA, DH keySize < 768, \
+ EC keySize < 224, DES40_CBC, RC4_40, 3DES_EDE_CBC
+
+ # Legacy algorithms for Secure Socket Layer/Transport Layer Security (SSL/TLS)
+ # processing in JSSE implementation.
+ #
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..860a94a688ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,125 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+
+_JVM=''; _JRE='glibc' # built in jre. This works best with 3.0.1 and 3.12.0 servers
+#_JVM='/usr/lib/jvm/java-11-openjdk'; _JRE='jre11-openjdk' # doesn't work
+#_JVM='/usr/lib/jvm/java-8-jre/jre'; _JRE='jre8'
+#_JVM='/usr/lib/jvm/java-8-openjdk/jre'; _JRE='jre8-openjdk' # doesn't work
+#_JVM='/usr/lib/jvm/java-7-jre/jre'; _JRE='jre7' # too old, not compatible
+
+set -u
+pkgname='mirth-connect-administrator-launcher'
+pkgver='1.2.0'
+pkgrel='1'
+pkgdesc='hl7 connector by Nextgen client'
+arch=('x86_64')
+url='https://www.nextgen.com/products-and-services/integration-engine'
+license=('MPL')
+depends=("${_JRE}")
+_srcdir='Mirth Connect Administrator Launcher'
+source=(
+ "https://s3.amazonaws.com/downloads.mirthcorp.com/connect-client-launcher/mirth-administrator-launcher-${pkgver}-unix.tar.gz"
+ '0000-mirth-connector-enable-DH768.patch'
+)
+md5sums=('3069335f10cc1d080cef7216cfb83401'
+ '34263d26eda5b5899969224bd3df1815')
+sha256sums=('63af212c5a95ab40eebf9249a214d89d23591e74d6e92ddcdfd42e5474d24d08'
+ '45c43153a3841bdba9a0a3e9ee7883f54daaec18a3558434912656bc02688ca9')
+
+prepare() {
+ set -u
+ cd "${_srcdir}"
+ if [ ! -z "${_JVM}" ]; then
+ sed -e "/^# INSTALL4J_JAVA_HOME_OVERRIDE=/ a INSTALL4J_JAVA_HOME_OVERRIDE='${_JVM}'" -i 'launcher' 'mcadministrator/unix/launch'
+ rm -rf 'jre'
+ else
+ # 3.0.1 defaulted to 768
+ #cd '..'; cp -pr "${_srcdir}" 'a'; ln -s "${_srcdir}" 'b'; false
+ # diff -pNaru5 'a' 'b' > '0000-mirth-connector-enable-DH768.patch'
+ patch -Nup1 -i "${srcdir}/0000-mirth-connector-enable-DH768.patch"
+ fi
+ set +u
+}
+
+package() {
+ set -u
+ cd "${_srcdir}"
+ install -d "${pkgdir}/usr/lib/${pkgname}/"
+ cp -pr . "${pkgdir}/usr/lib/${pkgname}"
+ rmdir "${pkgdir}/usr/lib/${pkgname}"/{logs,cache,data} # repeated below
+ rm -rf "${pkgdir}/usr/lib/${pkgname}"/{javachecker,mcadministrator}/{macos,windows,windows-x64}
+
+ if [ -d "${pkgdir}/usr/lib/${pkgname}/jre" ]; then
+ rm -rf "${pkgdir}/usr/lib/${pkgname}/jre/man"
+ local _p
+ for _p in "${pkgdir}/usr/lib/${pkgname}/jre/lib"/*.jar.pack "${pkgdir}/usr/lib/${pkgname}/jre/lib/ext"/*.jar.pack; do
+ jre/bin/unpack200 -r "${_p}" "${_p%.pack}"
+ done
+ fi
+
+ install -Dm755 <(cat << EOF
+#!/usr/bin/bash
+
+set -e
+set -u
+
+u="\$HOME/.${pkgname}"
+mkdir -p "\$u/"{mcadministrator/unix,logs,cache,data/icons}
+cd "\$u"
+if [ ! -f 'data/connections.json' ]; then
+ touch 'data/connections.json'
+fi
+if [ ! -f 'data/icons/null' ]; then
+ touch 'data/icons/null' # eliminate a seg fault for built in jre when Save As without an icon
+fi
+GLOBIGNORE=.
+for f in /usr/lib/${pkgname}/* /usr/lib/${pkgname}/.*; do
+ case "\${f##*/}" in
+ 'mcadministrator')
+ if [ -L "\${f##*/}" ]; then
+ rm -f "\${f##*/}"
+ fi
+ pushd "\${f##*/}/unix" > /dev/null
+ for g in /usr/lib/${pkgname}/mcadministrator/unix/* /usr/lib/${pkgname}/mcadministrator/unix/.*; do
+ case "\${g##*/}" in
+ launch|launch.vmoptions)
+ cp -p "\$g" "\${g##*/}"
+ ;;
+ *)
+ ln -sf "\$g"
+ ;;
+ esac
+ done
+ popd > /dev/null
+ ;;
+ 'launcher')
+ rm -f "\${f##*/}"
+ cp -p "\$f" "\${f##*/}"
+ ;;
+ *)
+ ln -sf "\$f"
+ ;;
+ esac
+done
+"./launcher" "\$@"
+
+EOF
+ ) "${pkgdir}/usr/bin/mirth-connect-administrator-launcher"
+
+ install -Dm644 <(cat << EOF
+[Desktop Entry]
+Name=Mirth Connect Administrator Launcher
+GenericName=Mirth Client
+Comment=Connect to Mirth servers
+Exec=/usr/bin/mirth-connect-administrator-launcher
+Terminal=false
+Type=Application
+#Icon=
+Categories=Application;Utility;
+MimeType=application/x-executable
+
+EOF
+ ) "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ set +u
+}
+set +u