summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLook2024-01-18 12:51:13 -0300
committerLook2024-01-18 12:51:13 -0300
commit7d9f020a84c0df14e8dba46185264cbbfa389a79 (patch)
tree19900f20a1c8dc8ba7640f63c77bc58051626626
parent4833620a3d9b2226cd3ee0283629f845e499df3d (diff)
downloadaur-7d9f020a84c0df14e8dba46185264cbbfa389a79.tar.gz
feat: prep for auto-update disable and version bump
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD15
-rw-r--r--miru.desktop11
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64d484c7318e..55aba253d529 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = miru-bin
pkgdesc = Bittorrent streaming software for cats
- pkgver = 4.5.8
+ pkgver = 4.5.9
pkgrel = 1
url = https://github.com/ThaUnknown/miru
install = miru-bin.install
@@ -9,7 +9,9 @@ pkgbase = miru-bin
depends = xdg-utils
options = !strip
options = !emptydirs
- source_x86_64 = https://github.com/ThaUnknown/miru/releases/download/v4.5.8/linux-Miru-4.5.8.deb
+ source_x86_64 = https://github.com/ThaUnknown/miru/releases/download/v4.5.9/linux-Miru-4.5.9.deb
+ source_x86_64 = miru.desktop
sha512sums_x86_64 = cc82982982455088d517e0aeb10b64524738058f0938f2adec4115ca1f11d19de6b068da174e487e860099207660e585d7b4c645bd5972bb592b028fec212713
+ sha512sums_x86_64 = 10ffce928a1f1785c78b23bd928e718a49f2243418aadd6e4537d83151c920ab270d7345e54646ae65351f855bdd41e41a9d3f0a94a128d618d85d9cc59e1e06
pkgname = miru-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1d0b4e2f0878..1cc869625dd7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Look <notkool@protonmail.com>
pkgname=miru-bin
-pkgver=4.5.8
+pkgver=4.5.9
pkgrel=1
pkgdesc="Bittorrent streaming software for cats"
arch=('x86_64')
@@ -9,8 +9,15 @@ license=('GPL-3.0')
depends=('xdg-utils')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-source_x86_64=("https://github.com/ThaUnknown/miru/releases/download/v${pkgver}/linux-Miru-${pkgver}.deb")
-sha512sums_x86_64=('cc82982982455088d517e0aeb10b64524738058f0938f2adec4115ca1f11d19de6b068da174e487e860099207660e585d7b4c645bd5972bb592b028fec212713')
+_pkgname="miru"
+source_x86_64=(
+ "https://github.com/ThaUnknown/miru/releases/download/v${pkgver}/linux-Miru-${pkgver}.deb"
+ "${_pkgname}.desktop"
+)
+sha512sums_x86_64=(
+ 'ebe5fb603508efe2b93e5f509ebf205965cbc24f3c9b09b3426fb39846bbe94ae017b1c7c7dc32836a6638b3148cec06547737686a20bb99238eea011c054841'
+ '10ffce928a1f1785c78b23bd928e718a49f2243418aadd6e4537d83151c920ab270d7345e54646ae65351f855bdd41e41a9d3f0a94a128d618d85d9cc59e1e06'
+)
package() {
@@ -18,5 +25,5 @@ package() {
tar -xJ -f data.tar.xz -C "${pkgdir}"
install -D -m644 "${pkgdir}/opt/Miru/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
+ install -D -m644 ${srcdir}/${_pkgname}.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
}
diff --git a/miru.desktop b/miru.desktop
new file mode 100644
index 000000000000..5c9b4d0c2c73
--- /dev/null
+++ b/miru.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Miru
+Exec=env DISABLE_AUTO_UPDATE=1 /opt/Miru/miru %U
+Terminal=false
+Type=Application
+Icon=miru
+StartupWMClass=Miru
+Comment=Bittorrent streaming software for cats
+Keywords=anime
+MimeType=x-scheme-handler/miru;
+Categories=AudioVideo;Video;