summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyngs2023-06-27 23:07:34 +0200
committerkyngs2023-06-27 23:07:34 +0200
commit0614d3df873efc49a0b32f2ca60680fa2f665652 (patch)
treea2d78d18aa3b291713b7c2109b5fc53c67fe7cb2
downloadaur-0614d3df873efc49a0b32f2ca60680fa2f665652.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..111cc0ed78db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = miru-git
+ pkgdesc = Bittorrent streaming software for cats
+ pkgver = 4.1.2
+ pkgrel = 1
+ url = https://github.com/ThaUnknown/miru
+ arch = any
+ license = GPL-3.0
+ depends = xdg-utils
+ depends = pnpm
+ conflicts = miru-bin
+ source = git+https://github.com/ThaUnknown/miru
+ sha256sums = SKIP
+
+pkgname = miru-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c613723a89ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: kyngs <aurmail at kyngs dot xyz>
+pkgname=miru-git
+pkgrel=1
+pkgver=4.1.2
+pkgdesc="Bittorrent streaming software for cats"
+arch=("any")
+url="https://github.com/ThaUnknown/miru"
+license=("GPL-3.0")
+depends=("xdg-utils" "pnpm")
+source=(
+ "git+${url}"
+)
+sha256sums=(
+ "SKIP"
+)
+conflicts=("miru-bin")
+
+pkgver() {
+ git -C "miru" describe --tags | sed 's/v//g'
+}
+
+build() {
+ cd "miru"
+ pnpm install
+ pnpm run build
+}
+
+package() {
+ cd "miru/dist"
+ ar vx "linux-Miru-${pkgver}.deb"
+
+ tar -xJ -f data.tar.xz -C "${pkgdir}"
+ install -D -m644 "${pkgdir}/opt/Miru/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}