summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornemesys2015-06-20 02:12:13 -0400
committernemesys2015-06-20 02:12:13 -0400
commitb9c4b28ee73a4628acd108974953c18c44fbdcf1 (patch)
treeeba04bfb6f3cc349c6e03b814ad83814bf5db75e
downloadaur-b9c4b28ee73a4628acd108974953c18c44fbdcf1.tar.gz
Initial commit
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
-rw-r--r--miscsplashutils-freetype-fix.patch60
4 files changed, 126 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..4c7f0f9f4c4d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = miscsplashutils
+ pkgdesc = Miscellaneous framebuffer utilities including fbres and fbtruetype
+ pkgver = 0.1.8
+ pkgrel = 5
+ url = http://dev.gentoo.org/~spock/projects/gensplash/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = freetype2
+ source = http://distfiles.gentoo.org/distfiles/miscsplashutils-0.1.8.tar.bz2
+ source = miscsplashutils-freetype-fix.patch
+
+pkgname = miscsplashutils
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fee12c94832
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = miscsplashutils
+ pkgdesc = Miscellaneous framebuffer utilities including fbres and fbtruetype
+ pkgver = 0.1.8
+ pkgrel = 5
+ url = http://dev.gentoo.org/~spock/projects/gensplash/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = freetype2
+ source = http://distfiles.gentoo.org/distfiles/miscsplashutils-0.1.8.tar.bz2
+ source = miscsplashutils-freetype-fix.patch
+ md5sums = 0a9505c5c5ed169e6158d2c1b06ff40b
+ md5sums = 05285f0a2b42e206e20e2973e69bd4c8
+
+pkgname = miscsplashutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6b4c8fd8d34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Heiko Baums <heiko@baums-on-web.de>
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+pkgname=miscsplashutils
+pkgver=0.1.8
+pkgrel=5
+pkgdesc='Miscellaneous framebuffer utilities including fbres and fbtruetype'
+arch=('i686' 'x86_64')
+url='http://dev.gentoo.org/~spock/projects/gensplash/'
+license=('GPL')
+depends=('freetype2')
+source=("http://distfiles.gentoo.org/distfiles/${pkgname}-${pkgver}.tar.bz2"
+ 'miscsplashutils-freetype-fix.patch')
+md5sums=('0a9505c5c5ed169e6158d2c1b06ff40b'
+ '05285f0a2b42e206e20e2973e69bd4c8')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ #Fix for static freetype and /usr/bin directory corrections.
+ patch -p1 -i "${srcdir}/miscsplashutils-freetype-fix.patch"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/usr" install
+
+ install -d "$pkgdir/usr/lib/splash/bin"
+ ln -s /usr/bin/wc "$pkgdir/usr/lib/splash/bin"
+
+ # install luxisri.ttf to avoid an x-server dependency
+ install -D -m644 fbtruetype/luxisri.ttf "$pkgdir/etc/splash/luxisri.ttf"
+}
diff --git a/miscsplashutils-freetype-fix.patch b/miscsplashutils-freetype-fix.patch
new file mode 100644
index 000000000000..bc262e325c5e
--- /dev/null
+++ b/miscsplashutils-freetype-fix.patch
@@ -0,0 +1,60 @@
+unchanged:
+--- Makefile 2007-06-09 10:43:16.000000000 -0400
++++ ./fbtruetype/Makefile 2014-09-11 09:18:41.067044105 -0400
+@@ -19,16 +19,14 @@
+
+ LIBDIR = $(PREFIX)/$(LIB)
+
+-PROGRAMS = fbtruetype fbtruetype.static
++PROGRAMS = fbtruetype
+ OBJECTS = fbtruetype.o messages.o console.o ttf.o luxisri.o
+
+ LDFLAGS += -L$(LIBDIR)
+-LIBSS = $(LIBDIR)/libfreetype.a $(LIBDIR)/libz.a -lm
+ LIBSD = -lfreetype -lm
+
+ CFLAGS += -I/usr/include/freetype2
+ COMPILE = $(CC) $(CFLAGS)
+-LINKS = $(CC) $(CFLAGS) $(LDFLAGS) -static -o $@
+ LINKD = $(CC) $(CFLAGS) $(LDFLAGS) -o $@
+
+ INSTALL_PROG = install
+@@ -47,20 +45,16 @@
+ mostlyclean:
+ -rm -f *.o core
+ clean: mostlyclean
+- -rm -f fbtruetype fbtruetype.static
++ -rm -f fbtruetype
+
+ fbtruetype: $(OBJECTS)
+ @rm -f fbtruetype
+ $(LINKD) $(LDFLAGS) $(OBJECTS) $(LIBSD)
+-fbtruetype.static: $(OBJECTS)
+- @rm -f fbtruetype.static
+- $(LINKS) $(LDFLAGS) $(OBJECTS) $(LIBSS)
+
+ install:
+- $(INSTALL_PROG) -D fbtruetype $(DESTDIR)/sbin/fbtruetype
+- $(INSTALL_PROG) -D fbtruetype.static $(DESTDIR)/sbin/fbtruetype.static
++ $(INSTALL_PROG) -D fbtruetype $(DESTDIR)/bin/fbtruetype
+
+ strip: $(PROGRAMS)
+ $(STRIP) -s $(PROGRAMS)
+
+-.PHONY: mostlyclean clean fbtruetype fbtruetype.static all strip
++.PHONY: mostlyclean clean fbtruetype all strip
+only in patch2:
+unchanged:
+--- ./fbtruetype/ttf.c 2006-02-03 10:10:41.000000000 -0500
++++ ./fbtruetype/ttf.c 2014-09-11 09:07:32.005039477 -0400
+@@ -13,8 +13,8 @@
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+ /* #include <freetype/freetype.h> */
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include FT_OUTLINE_H
++#include FT_TRUETYPE_IDS_H
+
+ #include "ttf.h"
+