summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMao Wtm2019-05-01 10:36:39 +0800
committerMao Wtm2019-05-01 10:36:39 +0800
commite42e403318cab5b6becc6675d91b51368f98f866 (patch)
tree1998e0ca5fd2159cd29e8ef8c86c048b9035f69b
downloadaur-e42e403318cab5b6becc6675d91b51368f98f866.tar.gz
Add package misspell
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70a9882ae866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = misspell
+ pkgdesc = Correct commonly misspelled English words in source files
+ pkgver = v0.3.4
+ pkgrel = 1
+ url = https://github.com/client9/misspell/
+ arch = any
+ license = MIT
+ makedepends = go
+ source = misspell-src::git+https://github.com/client9/misspell.git#tag=v0.3.4
+ sha256sums = SKIP
+
+pkgname = misspell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53c4abf501cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mao Wtm <m@maowtm.org>
+pkgname=misspell
+pkgver=v0.3.4
+pkgver() {
+ cd "$pkgname-src"
+ git describe | cut -d- -f1
+}
+pkgrel=1
+pkgdesc="Correct commonly misspelled English words in source files"
+arch=(any)
+url="https://github.com/client9/misspell/"
+license=('MIT')
+makedepends=('go')
+source=("$pkgname-src::git+https://github.com/client9/misspell.git#tag=$pkgver")
+sha256sums=("SKIP")
+
+build() {
+ mkdir -p go/src/github.com/client9/
+ cp -r $pkgname-src go/src/github.com/client9/$pkgname
+ cd go
+ export GOPATH=$(pwd)
+ cd src/github.com/client9/$pkgname
+ go get -v
+ make install
+}
+
+package() {
+ install -s -DT go/bin/misspell $pkgdir/usr/bin/misspell
+}
+