summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-03-12 20:50:33 +0100
committer5chdn2016-03-12 20:50:33 +0100
commit813ee5a6a900439ae6ec38f968373058d6fa86ae (patch)
tree03f5153e8450dac1a6c1148f8b4bd34641299f67
parent88796a9c16ae1d4a502cd482d98499bbe6d270c0 (diff)
downloadaur-813ee5a6a900439ae6ec38f968373058d6fa86ae.tar.gz
Make geth executable.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfdb22ceb57f..5bcd3166954e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 19:12:15 UTC 2016
+# Sat Mar 12 19:50:10 UTC 2016
pkgbase = mist
pkgdesc = Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser).
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ethereum/mist
arch = i686
arch = x86_64
@@ -15,10 +15,14 @@ pkgbase = mist
depends = qt5-quickcontrols
depends = qt5-webengine
depends = readline
- optdepends = geth: The go-ethereum commandline client.
optdepends = ethereum: The cpp-ethereum commandline client.
+ provides = geth
provides = mist
provides = libnode
+ conflicts = geth
+ conflicts = geth-git
+ conflicts = go-ethereum
+ conflicts = go-ethereum-git
conflicts = mist-git
conflicts = libnode
conflicts = libnode-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d604644890e..c4b99d83fa96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mist
pkgver=0.5.1
_pkgver=0-5-1
-pkgrel=1
+pkgrel=2
pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser)."
arch=('i686' 'x86_64')
depends=(
@@ -17,16 +17,20 @@ depends=(
'readline'
)
provides=(
+ 'geth'
'mist'
'libnode'
)
conflicts=(
+ 'geth'
+ 'geth-git'
+ 'go-ethereum'
+ 'go-ethereum-git'
'mist-git'
'libnode'
'libnode-git'
)
optdepends=(
- 'geth: The go-ethereum commandline client.'
'ethereum: The cpp-ethereum commandline client.'
)
url="https://github.com/ethereum/mist"
@@ -61,7 +65,10 @@ package() {
install -Dm644 "${srcdir}/mist.desktop" "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/bin"
+ chmod +x "/usr/share/${pkgname}/Ethereum-Wallet"
+ chmod +x "/usr/share/${pkgname}/resources/node/geth/geth"
ln -s "/usr/share/${pkgname}/Ethereum-Wallet" "${pkgdir}/usr/bin/mist"
+ ln -s "/usr/share/${pkgname}/resources/node/geth/geth" "${pkgdir}/usr/bin/geth"
install -Dm644 "${pkgdir}/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
rm "${pkgdir}/usr/share/${pkgname}/LICENSE"