summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-01-25 12:46:38 +0100
committer5chdn2016-01-25 12:46:38 +0100
commitdd2573457f5ec23f67b61c5e9a1a166d20075a8e (patch)
tree2f11b635b78f1639bafef82f4eaa7e203aa0c723
parent8e19441aaca0185426c09b7f9a5ef43c260613f4 (diff)
downloadaur-dd2573457f5ec23f67b61c5e9a1a166d20075a8e.tar.gz
Add ia32 architecture builds
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1366408b905..f786f464ca90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Mon Jan 25 11:35:12 UTC 2016
+# Mon Jan 25 11:45:51 UTC 2016
pkgbase = mist
pkgdesc = Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser).
pkgver = 0.3.8
pkgrel = 3
url = https://github.com/ethereum/mist
+ arch = i686
arch = x86_64
license = GPL
depends = gmp
@@ -21,7 +22,9 @@ pkgbase = mist
conflicts = mist-git
conflicts = libnode
conflicts = libnode-git
- source = mist-0-3-8.zip::https://github.com/ethereum/mist/releases/download/v0.3.8/Ethereum-Wallet-linux64-0-3-8.zip
+ source = mist-0-3-8-ia32.zip::https://github.com/ethereum/mist/releases/download/v0.3.8/Ethereum-Wallet-linux32-0-3-8.zip
+ source = mist-0-3-8-x64.zip::https://github.com/ethereum/mist/releases/download/v0.3.8/Ethereum-Wallet-linux64-0-3-8.zip
+ sha256sums = d2ee41e54d3a19ca2e35b5792c79401941bf3bd935be6b8288b135cbf121c552
sha256sums = 6a96a2e18e21ce8b1995b508e05d7a59a701a5aa75a82624c4286a7f8ec9eee5
pkgname = mist
diff --git a/PKGBUILD b/PKGBUILD
index a4dc35892621..0bfd22a347ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver=0.3.8
_pkgver=0-3-8
pkgrel=3
pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser)."
-arch=('x86_64')
+arch=('i686' 'x86_64')
depends=(
'gmp'
'leveldb'
@@ -31,15 +31,27 @@ optdepends=(
)
url="https://github.com/ethereum/mist"
license=('GPL')
-source=("${pkgname}-${_pkgver}.zip::https://github.com/ethereum/$pkgname/releases/download/v${pkgver}/Ethereum-Wallet-linux64-$_pkgver.zip")
-sha256sums=("6a96a2e18e21ce8b1995b508e05d7a59a701a5aa75a82624c4286a7f8ec9eee5")
+source=(
+ "${pkgname}-${_pkgver}-ia32.zip::https://github.com/ethereum/$pkgname/releases/download/v${pkgver}/Ethereum-Wallet-linux32-$_pkgver.zip"
+ "${pkgname}-${_pkgver}-x64.zip::https://github.com/ethereum/$pkgname/releases/download/v${pkgver}/Ethereum-Wallet-linux64-$_pkgver.zip"
+)
+sha256sums=(
+ "d2ee41e54d3a19ca2e35b5792c79401941bf3bd935be6b8288b135cbf121c552"
+ "6a96a2e18e21ce8b1995b508e05d7a59a701a5aa75a82624c4286a7f8ec9eee5"
+)
package() {
- rm "${srcdir}/${pkgname}-${_pkgver}.zip"
+
+ _arch="ia32"
+ if [ "${CARCH}" = "x86_64" ]; then
+ _arch="x64"
+ fi
+
+ rm "${srcdir}/${pkgname}-${_pkgver}-${_arch}.zip"
msg2 'Installing Mist...'
install -d "${pkgdir}/usr/share/${pkgname}"
- cp -a "${srcdir}/Ethereum-Wallet-linux-x64-${_pkgver}/." "${pkgdir}/usr/share/${pkgname}"
+ cp -a "${srcdir}/Ethereum-Wallet-linux-${_arch}-${_pkgver}/." "${pkgdir}/usr/share/${pkgname}"
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/${pkgname}/Ethereum-Wallet" "${pkgdir}/usr/bin/mist"