summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2015-12-28 14:42:30 +0100
committer5chdn2015-12-28 14:42:30 +0100
commite96757f178fc96ded3519e05175a60ef44737d15 (patch)
tree1abbd5ff82066a5da657508af457d4d80dce3ac9
parentbe47ab90716e0e79e621aa2426e24af5804fe4f8 (diff)
downloadaur-e96757f178fc96ded3519e05175a60ef44737d15.tar.gz
Update to latest beta4 release.
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD89
-rw-r--r--mist.install17
3 files changed, 61 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0cc7cd83984..67870df3f7d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
+# Generated by mksrcinfo v8
+# Mon Dec 28 13:41:51 UTC 2015
pkgbase = mist
- pkgdesc = Ether Browser for Ethereum
- pkgver = 20150519
- pkgrel = 1
- url = https://github.com/ethereum/go-ethereum
- install = mist.install
- arch = i686
+ pkgdesc = Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser and Geth cli).
+ pkgver = 0.3.7
+ pkgrel = 2
+ url = https://github.com/ethereum/mist
arch = x86_64
groups = ethereum
license = GPL
- makedepends = gcc
- makedepends = git
- makedepends = go
- makedepends = godep
- makedepends = make
- makedepends = mercurial
depends = gmp
depends = leveldb
depends = qt5-base
@@ -21,9 +15,17 @@ pkgbase = mist
depends = qt5-quickcontrols
depends = qt5-webengine
depends = readline
- optdepends = go-ethereum: Ethereum Go developer client (CLI)
- options = !strip
- options = !emptydirs
+ provides = mist
+ provides = libnode
+ provides = geth
+ conflicts = mist-git
+ conflicts = libnode
+ conflicts = geth
+ conflicts = geth-git
+ conflicts = go-ethereum
+ conflicts = go-ethereum-git
+ source = mist.zip::https://github.com/ethereum/mist/releases/download/0.3.7/Ethereum-Wallet-linux64-0-3-7.zip
+ sha256sums = 00d088bb5d28784217a6dcd2d51567755e8fcf4601f76aa6ce18c831fd1b3d77
pkgname = mist
diff --git a/PKGBUILD b/PKGBUILD
index b6f42df37941..d1b49ec6b1db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,12 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Maintainer: Ordoe Ordoe <aur@cach.co>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=mist
-pkgver=20150519
-pkgrel=1
-pkgdesc="Ether Browser for Ethereum"
-arch=('i686' 'x86_64')
+pkgver=0.3.7
+_pkgver=0-3-7
+pkgrel=2
+pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser and Geth cli)."
+arch=('x86_64')
depends=('gmp'
'leveldb'
'qt5-base'
@@ -12,49 +14,46 @@ depends=('gmp'
'qt5-quickcontrols'
'qt5-webengine'
'readline')
-makedepends=('gcc'
- 'git'
- 'go'
- 'godep'
- 'make'
- 'mercurial')
-optdepends=('go-ethereum: Ethereum Go developer client (CLI)')
+provides=('mist'
+ 'libnode'
+ 'geth')
+conflicts=('mist-git'
+ 'libnode'
+ 'geth'
+ 'geth-git'
+ 'go-ethereum'
+ 'go-ethereum-git')
groups=('ethereum')
-url="https://github.com/ethereum/go-ethereum"
+url="https://github.com/ethereum/$pkgname"
license=('GPL')
-options=('!strip' '!emptydirs')
-install=mist.install
+source=("${pkgname}.zip::https://github.com/ethereum/$pkgname/releases/download/$pkgver/Ethereum-Wallet-linux64-$_pkgver.zip")
+sha256sums=("00d088bb5d28784217a6dcd2d51567755e8fcf4601f76aa6ce18c831fd1b3d77")
-pkgver() {
- date +%Y%m%d
-}
+package() {
+ rm "${srcdir}/${pkgname}.zip"
-build() {
- msg2 'Building...'
- export GOPATH="$srcdir"
- go get -d github.com/ethereum/go-ethereum/...
- cd "$srcdir/src/github.com/ethereum/go-ethereum" && git checkout develop
- godep restore
- cd ./cmd/mist && go install
-}
+ msg2 'Installing Mist...'
+ install -d "${pkgdir}/usr/share/${pkgname}"
+ cp -a "${srcdir}/Ethereum-Wallet-linux-x64-${_pkgver}/." "${pkgdir}/usr/share/${pkgname}"
-package() {
- msg2 'Installing Mist assets...'
- install -dm 755 "$pkgdir/usr/share/mist/src"
- for _lib in `find "$srcdir/src" -mindepth 1 -maxdepth 1 -printf '%f\n'`; do
- cp -dpr --no-preserve=ownership "$srcdir/src/$_lib" "$pkgdir/usr/share/mist/src/$_lib"
- done
- mv "$pkgdir/usr/share/mist/src/github.com/ethereum/go-ethereum/cmd/mist/assets"/* \
- "$pkgdir/usr/share/mist" && rm -rf "$pkgdir/usr/share/mist/src"
-
- msg2 'Installing Mist binary...'
- for _bin in `find "$srcdir/bin" -mindepth 1 -maxdepth 1 -type f -printf '%f\n'`; do
- install -Dm 755 "$srcdir/bin/$_bin" "$pkgdir/usr/bin/$_bin"
- done
-
- msg2 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
- find "$pkgdir" -type d -name .hg -exec rm -r '{}' +
- find "$pkgdir" -type f -name .hgignore -exec rm -r '{}' +
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/usr/share/${pkgname}/Ethereum-Wallet" "${pkgdir}/usr/bin/mist"
+
+ install -Dm644 "${pkgdir}/usr/share/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm "${pkgdir}/usr/share/${pkgname}/LICENSE"
+
+ msg2 'Installing Libnode...'
+ install -d "${pkgdir}/usr/lib"
+ ln -s "/usr/share/${pkgname}/libnode.so" "${pkgdir}/usr/lib/libnode.so"
+
+ ln -sf "/usr/lib/libgcrypt.so.11" "${pkgdir}/usr/share/${pkgname}/libgcrypt.so.11"
+ ln -sf "/usr/lib/libnotify.so.4" "${pkgdir}/usr/share/${pkgname}/libnotify.so.4"
+
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+ find "${pkgdir}" -type f -exec chmod 644 {} +
+ chmod 755 "${pkgdir}/usr/share/${pkgname}/Ethereum-Wallet"
+ chmod 755 "${pkgdir}/usr/share/${pkgname}/libnode.so"
+
+ msg2 'Installing Geth...'
+ install -m 755 "$srcdir/Ethereum-Wallet-linux-x64-$_pkgver/resources/node/geth/geth" "$pkgdir/usr/bin/geth"
}
diff --git a/mist.install b/mist.install
deleted file mode 100644
index 5be273576058..000000000000
--- a/mist.install
+++ /dev/null
@@ -1,17 +0,0 @@
-post_install() {
- printf "$mist\n"
-}
-
-post_upgrade() {
- post_install
-}
-
-read -d '' mist <<'EOF'
-To start Mist:
-
- $ mist -asset_path="/usr/share/mist"
-
-Or create a shell alias:
-
- alias mist='mist -asset_path="/usr/share/mist"'
-EOF