summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-01-25 13:03:05 +0100
committer5chdn2016-01-25 13:03:05 +0100
commit0ed86770c203da6d3fe917a33462adb7b94ea937 (patch)
treedc9c32b7a8589c1f5a098d11c2df9d7a56cc2854
parent10f34708219214c04f6aba611922346a90280315 (diff)
downloadaur-0ed86770c203da6d3fe917a33462adb7b94ea937.tar.gz
Add ia32 architecture builds
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD68
2 files changed, 49 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3395f332f6d..35d4efb8a3eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Wed Jan 20 11:47:15 UTC 2016
+# Mon Jan 25 12:02:26 UTC 2016
pkgbase = mist-git
pkgdesc = Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser).
- pkgver = 0.3.7.r0.g3e8b9dc
- pkgrel = 2
+ pkgver = v0.3.8.r2.g64cb59b
+ pkgrel = 1
url = https://github.com/ethereum/mist
+ arch = i686
arch = x86_64
license = GPL
makedepends = nodejs
@@ -20,7 +21,8 @@ pkgbase = mist-git
depends = readline
depends = meteor-js
depends = electron
- depends = geth-git
+ optdepends = geth: The go-ethereum commandline client.
+ optdepends = ethereum: The cpp-ethereum commandline client.
provides = mist
provides = libnode
conflicts = mist
diff --git a/PKGBUILD b/PKGBUILD
index 9a8d8a88ddca..16dcfc96324a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,56 @@
pkgname=mist-git
_pkgname=mist
-pkgver=0.3.7.r0.g3e8b9dc
-_pkgver=0-3-7
-pkgrel=2
+pkgver=v0.3.8.r2.g64cb59b
+_pkgver=0-3-8
+pkgrel=1
pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser)."
-arch=('x86_64')
-depends=('gmp'
- 'leveldb'
- 'qt5-base'
- 'qt5-declarative'
- 'qt5-quickcontrols'
- 'qt5-webengine'
- 'readline'
- 'meteor-js'
- 'electron'
- 'geth-git')
-makedepends=('nodejs'
- 'npm'
- 'meteor-build-client'
- 'gulp')
-provides=('mist'
- 'libnode')
-conflicts=('mist'
- 'libnode'
- 'libnode-git')
+arch=('i686' 'x86_64')
+depends=(
+ 'gmp'
+ 'leveldb'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-quickcontrols'
+ 'qt5-webengine'
+ 'readline'
+ 'meteor-js'
+ 'electron'
+)
+makedepends=(
+ 'nodejs'
+ 'npm'
+ 'meteor-build-client'
+ 'gulp'
+)
+provides=(
+ 'mist'
+ 'libnode'
+)
+conflicts=(
+ 'mist'
+ 'libnode'
+ 'libnode-git'
+)
+optdepends=(
+ 'geth: The go-ethereum commandline client.'
+ 'ethereum: The cpp-ethereum commandline client.'
+)
url="https://github.com/ethereum/mist"
license=('GPL')
source=("${pkgname}::git+https://github.com/ethereum/mist")
sha256sums=("SKIP")
pkgver() {
- cd ${pkgname}
+ cd ${srcdir}/${pkgname}
+ git checkout -q develop
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
msg2 'Building Mist...'
cd ${srcdir}/${pkgname}
+ git checkout develop
git submodule update --init
npm install electron-prebuilt
npm install meteor-build-client
@@ -48,9 +61,14 @@ build() {
}
package() {
+ _arch="ia32"
+ if [ "${CARCH}" = "x86_64" ]; then
+ _arch="x64"
+ fi
+
msg2 'Installing Mist...'
install -d "${pkgdir}/usr/share/mist"
- cp -a "${srcdir}/${pkgname}/dist_wallet/Ethereum-Wallet-linux-x64-${_pkgver}/." "${pkgdir}/usr/share/${_pkgname}"
+ cp -a "${srcdir}/${pkgname}/dist_wallet/Ethereum-Wallet-linux-${_arch}-${_pkgver}/." "${pkgdir}/usr/share/${_pkgname}"
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/${_pkgname}/Ethereum-Wallet" "${pkgdir}/usr/bin/mist"