summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author5chdn2016-03-12 20:50:46 +0100
committer5chdn2016-03-12 20:50:46 +0100
commit596080f6e89b303a4c4ef78f737a56b0f4833822 (patch)
treec1b335c2b8ed5617910ccaacee9ee87aca928e6d
parentabcce705932f2636bcc8624617681d0eeab94eb4 (diff)
downloadaur-596080f6e89b303a4c4ef78f737a56b0f4833822.tar.gz
Make geth executable.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fae80009518b..0032f3f8039c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 19:25:30 UTC 2016
+# Sat Mar 12 19:50:12 UTC 2016
pkgbase = mist-git
pkgdesc = Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser).
- pkgver = 0.5.1.r0.g75d28b3
- pkgrel = 1
+ pkgver = 0.5.1.r25.g661f46a
+ pkgrel = 2
url = https://github.com/ethereum/mist
arch = i686
arch = x86_64
@@ -21,10 +21,14 @@ pkgbase = mist-git
depends = readline
depends = meteor-js
depends = electron
- optdepends = geth: The go-ethereum commandline client.
optdepends = ethereum: The cpp-ethereum commandline client.
+ provides = geth
provides = mist
provides = libnode
+ conflicts = geth
+ conflicts = geth-git
+ conflicts = go-ethereum
+ conflicts = go-ethereum-git
conflicts = mist
conflicts = libnode
conflicts = libnode-git
diff --git a/PKGBUILD b/PKGBUILD
index 8bd32a8cecac..32d9f1c13bdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgname=mist-git
_pkgname=mist
-pkgver=0.5.1.r0.g75d28b3
-_pkgver=0-5-1
-pkgrel=1
+pkgver=0.5.1.r25.g661f46a
+_pkgver=0-5-2
+pkgrel=2
pkgdesc="Ethereum wallet for Ether accounts, wallets and smart contracts (includes Mist browser)."
arch=('i686' 'x86_64')
depends=(
@@ -25,16 +25,20 @@ makedepends=(
'gulp'
)
provides=(
+ 'geth'
'mist'
'libnode'
)
conflicts=(
+ 'geth'
+ 'geth-git'
+ 'go-ethereum'
+ 'go-ethereum-git'
'mist'
'libnode'
'libnode-git'
)
optdepends=(
- 'geth: The go-ethereum commandline client.'
'ethereum: The cpp-ethereum commandline client.'
)
url="https://github.com/ethereum/mist"
@@ -85,7 +89,10 @@ package() {
install -Dm644 "${srcdir}/mist.desktop" "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/bin"
+ chmod +x "/usr/share/${_pkgname}/Ethereum-Wallet"
+ chmod +x "/usr/share/${_pkgname}/resources/node/geth/geth"
ln -s "/usr/share/${_pkgname}/Ethereum-Wallet" "${pkgdir}/usr/bin/mist"
+ ln -s "/usr/share/${_pkgname}/resources/node/geth/geth" "${pkgdir}/usr/bin/geth"
install -Dm644 "${pkgdir}/usr/share/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
rm "${pkgdir}/usr/share/${_pkgname}/LICENSE"