summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKohei Suzuki2016-12-06 02:51:03 +0900
committerKohei Suzuki2016-12-06 02:51:23 +0900
commitc07fd83d919abc931c52acc311f761c747d5f4cf (patch)
tree8e6ca8e66550f7015c2f75e68449c1c33d722fe4
downloadaur-c07fd83d919abc931c52acc311f761c747d5f4cf.tar.gz
mitamae v1.1.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20b23b9ed7be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mitamae
+ pkgdesc = Configuration management tool embedding mruby
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/k0kubun/mitamae
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = ruby
+ makedepends = git
+ depends = glibc
+ source = https://github.com/k0kubun/mitamae/archive/v1.1.2.tar.gz
+ sha512sums = 57d2c4fe093ee729e8d35799dcafc1b5ea92e34dd7a3ab17e3f2ce0fef612368d3b5d09f2a9d18891fc52ff24ae18ff755b4ff8319bcd0ba534b436cd78df893
+
+pkgname = mitamae
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5038992e9ed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kohei Suzuki <eagletmt@gmail.com>
+pkgname=mitamae
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Configuration management tool embedding mruby"
+arch=('i686' 'x86_64')
+url="https://github.com/k0kubun/mitamae"
+license=('MIT')
+depends=('glibc')
+makedepends=('ruby' 'git')
+source=("https://github.com/k0kubun/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('57d2c4fe093ee729e8d35799dcafc1b5ea92e34dd7a3ab17e3f2ce0fef612368d3b5d09f2a9d18891fc52ff24ae18ff755b4ff8319bcd0ba534b436cd78df893')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ rake compile
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/share/licenses/$pkgname"
+ install -m755 mruby/build/host/bin/mitamae "$pkgdir/usr/bin/"
+ install -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/"
+}