summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2018-07-12 12:34:39 +0200
committerMartin T. H. Sandsmark2018-07-12 12:40:18 +0200
commit70c9967b7ad7dc69d7419a9f548280a3191e44e0 (patch)
tree431a21741335fe731d231c19be9e983cc52a0275
downloadaur-70c9967b7ad7dc69d7419a9f548280a3191e44e0.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b729c98ff2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mitie-git
+ pkgdesc = MITIE: library and tools for information extraction
+ pkgver = r5148.15bed499
+ pkgrel = 1
+ url = https://github.com/mit-nlp/MITIE
+ arch = i686
+ arch = x86_64
+ license = Boost Software License
+ depends = openblas
+ provides = mitie
+ conflicts = mitie
+ replaces = mitie
+ source = git+https://github.com/mit-nlp/MITIE
+ sha256sums = SKIP
+
+pkgname = mitie-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6acd8e5eb90f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: sandsmark <martin.sandsmark@kde.org>
+
+pkgname=mitie-git
+_pkgname=MITIE
+pkgrel=1
+pkgver=r5148.15bed499
+pkgdesc="MITIE: library and tools for information extraction"
+arch=('i686' 'x86_64')
+url="https://github.com/mit-nlp/MITIE"
+license=('Boost Software License')
+depends=('openblas')
+source=("git+https://github.com/mit-nlp/${_pkgname}")
+sha256sums=(SKIP)
+provides=('mitie')
+conflicts=('mitie')
+replaces=('mitie')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}/mitielib"
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/mitielib/"
+
+ # The install target in the CMakeLists.txt is broken
+ install -d -m755 "${pkgdir}/usr/lib/"
+ install -m755 build/libmitie.so "${pkgdir}/usr/lib/"
+
+ install -d -m755 "${pkgdir}/usr/include/mitie/"
+ install -m644 include/mitie/*.h "${pkgdir}/usr/include/mitie/"
+}