summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLipman2021-04-11 15:13:06 +0800
committerLipman2021-04-11 15:13:06 +0800
commitc56476e067a507cb3aec06b5354ddb38b368f3cf (patch)
tree92aaaa2db0aa99684ca28a7aa12c553c443bfd2c
downloadaur-c56476e067a507cb3aec06b5354ddb38b368f3cf.tar.gz
MITK-2021.02 package
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD30
-rw-r--r--mitk-workbench8
-rw-r--r--mitk-workbench.desktop10
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..400f655430f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mitk
+ pkgdesc = Medical Imaging Interaction Toolkit (MITK) is a free open-source software system for development of interactive medical image processing software.
+ pkgver = 2021.02
+ pkgrel = 1
+ url = https://mitk.org
+ arch = x86_64
+ license = BSD
+ depends = libwrap
+ depends = qt5-svg
+ depends = qt5-tools
+ depends = qt5-webengine
+ options = !strip
+ source = https://www.mitk.org/download/releases/MITK-2021.02/Ubuntu%2020.04/MITK-v2021.02-linux-x86_64.tar.gz
+ source = LICENSE
+ source = mitk-workbench
+ source = mitk-workbench.desktop
+ md5sums = 8c39aece3a4226b950dc18fcdcbfb2b9
+ md5sums = e559d78ebaf8764cbef89a26d3fcbfe6
+ md5sums = c660294bae6faf808acf0c659d64f372
+ md5sums = 96fab1bb6f6eea48c3a1bf8f525635ba
+
+pkgname = mitk
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..4cd2f3576a74
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+BSD 3-Clause License
+
+Copyright (c) 2003-2021, German Cancer Research Center (DKFZ)
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this
+ list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+3. Neither the name of the copyright holder nor the names of its
+ contributors may be used to endorse or promote products derived from
+ this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
+OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6cd45cfd4fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Pan Li <lipan19@mails.jlu.edu.cn>
+
+pkgname=mitk
+pkgver=2021.02
+pkgrel=1
+pkgdesc="Medical Imaging Interaction Toolkit (MITK) is a free open-source software system for development of interactive medical image processing software."
+arch=('x86_64')
+url="https://mitk.org"
+license=('BSD')
+depends=('libwrap' 'qt5-svg' 'qt5-tools' 'qt5-webengine')
+source=("https://www.mitk.org/download/releases/MITK-2021.02/Ubuntu%2020.04/MITK-v2021.02-linux-x86_64.tar.gz"
+ "LICENSE"
+ "mitk-workbench"
+ "mitk-workbench.desktop")
+md5sums=('8c39aece3a4226b950dc18fcdcbfb2b9'
+ 'e559d78ebaf8764cbef89a26d3fcbfe6'
+ 'c660294bae6faf808acf0c659d64f372'
+ '96fab1bb6f6eea48c3a1bf8f525635ba')
+
+options=(!strip)
+
+package() {
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -d "${pkgdir}/opt/${pkgname}-${pkgver}"
+ cp -r "${srcdir}/MITK-v${pkgver}-linux-${arch}/bin" "${pkgdir}/opt/${pkgname}-${pkgver}/"
+ install -d "${pkgdir}/usr/share/pixmaps/"
+ cp -r "${srcdir}/MITK-v${pkgver}-linux-${arch}/bin/mitk.ico" "${pkgdir}/usr/share/pixmaps/"
+ install -Dm755 "${srcdir}/mitk-workbench" "${pkgdir}/usr/bin/mitk-workbench"
+ install -Dm644 "${srcdir}/mitk-workbench.desktop" "${pkgdir}/usr/share/applications/mitk-workbench.desktop"
+}
diff --git a/mitk-workbench b/mitk-workbench
new file mode 100644
index 000000000000..23ba1c87a732
--- /dev/null
+++ b/mitk-workbench
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+MITK_DIR="/opt/mitk-2021.02/bin"
+
+export QT_PLUGIN_PATH="/usr/lib/qt/plugins"
+export LD_LIBRARY_PATH="$MITK_DIR:$MITK_DIR/plugins:$LD_LIBRARY_PATH"
+
+exec "$MITK_DIR/MitkWorkbench" $@
diff --git a/mitk-workbench.desktop b/mitk-workbench.desktop
new file mode 100644
index 000000000000..62dc7254486e
--- /dev/null
+++ b/mitk-workbench.desktop
@@ -0,0 +1,10 @@
+ [Desktop Entry]
+Name=MITK Workbench
+GenericName=Image Visualization
+Comment=Medical Imaging Interaction Toolkit (MITK) Workbench
+Exec=mitk-workbench %U
+TryExec=mitk-workbench
+Terminal=false
+Type=Application
+Categories=Graphics;Science
+MimeType=image/jpeg;image/png;image/tiff