summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-12-10 22:01:17 +0100
committerSonic-Y3k2015-12-10 22:01:17 +0100
commit31247271f794185a53e978460e0e38a6260fc2a8 (patch)
treebe853706b23835cf6ed71b424d3df0a1da70b6f5
parentbcc9d1b6873e6767689fa77cc1064c5377f23153 (diff)
downloadaur-31247271f794185a53e978460e0e38a6260fc2a8.tar.gz
Added python2-ua-parser dependency
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--chdir.patch17
3 files changed, 30 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index caad003c2822..2c9c3cf7401b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
# Generated by mksrcinfo v8
-# Thu Dec 10 20:15:02 UTC 2015
+# Thu Dec 10 21:00:51 UTC 2015
pkgbase = mitmf-git
pkgdesc = Framework for Man-In-The-Middle attacks.
pkgver = r425.d542dc1
pkgrel = 1
url = https://github.com/byt3bl33d3r/MITMf
arch = any
- license = unknown
+ license = GNU
makedepends = git
depends = python2
depends = libnetfilter_queue
@@ -25,7 +25,7 @@ pkgbase = mitmf-git
depends = python2-lxml
depends = python2-pefile-git
depends = python2-ipy
- depends = python2-user_agent
+ depends = python2-user-agents
depends = python2-pyopenssl
depends = python2-service-identity
depends = python2-configobj
@@ -39,10 +39,13 @@ pkgbase = mitmf-git
depends = python2-pypcap
depends = python2-chardet
depends = python2-netfilterqueue-git
+ depends = python2-ua-parser
provides = mitmf
options = !strip
source = mitmf-git::git+https://github.com/byt3bl33d3r/MITMf
+ source = chdir.patch
sha256sums = SKIP
+ sha256sums = fa44f049c26e3bf2f911def34d70c047679217ded4612eb2996c5444245c3939
pkgname = mitmf-git
diff --git a/PKGBUILD b/PKGBUILD
index a3876c899cb5..ba75ea1252fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,14 @@ pkgver=r425.d542dc1
pkgrel=1
arch=('any')
url="https://github.com/byt3bl33d3r/MITMf"
-license=('unknown')
+license=('GNU')
provides=('mitmf')
makedepends=('git')
-depends=('python2' 'libnetfilter_queue' 'libpcap' 'libjpeg-turbo' 'capstone' 'python2-pyinotify' 'python2-crypto' 'python2-pyasn1' 'python2-cryptography' 'python2-pillow' 'python2-netaddr' 'scapy' 'python2-dnslib' 'python2-twisted' 'python2-lxml' 'python2-pefile-git' 'python2-ipy' 'python2-user_agent' 'python2-pyopenssl' 'python2-service-identity' 'python2-configobj' 'python2-flask' 'python2-dnspython' 'python2-beautifulsoup4' 'python2-capstone' 'python2-magic' 'python2-msgpack' 'python2-requests' 'python2-pypcap' 'python2-chardet' 'python2-netfilterqueue-git')
-source=("${pkgname}::git+https://github.com/byt3bl33d3r/MITMf")
-sha256sums=('SKIP')
+depends=('python2' 'libnetfilter_queue' 'libpcap' 'libjpeg-turbo' 'capstone' 'python2-pyinotify' 'python2-crypto' 'python2-pyasn1' 'python2-cryptography' 'python2-pillow' 'python2-netaddr' 'scapy' 'python2-dnslib' 'python2-twisted' 'python2-lxml' 'python2-pefile-git' 'python2-ipy' 'python2-user-agents' 'python2-pyopenssl' 'python2-service-identity' 'python2-configobj' 'python2-flask' 'python2-dnspython' 'python2-beautifulsoup4' 'python2-capstone' 'python2-magic' 'python2-msgpack' 'python2-requests' 'python2-pypcap' 'python2-chardet' 'python2-netfilterqueue-git' 'python2-ua-parser')
+source=("${pkgname}::git+https://github.com/byt3bl33d3r/MITMf"
+ "chdir.patch")
+sha256sums=('SKIP'
+ 'fa44f049c26e3bf2f911def34d70c047679217ded4612eb2996c5444245c3939')
options=(!strip)
pkgver() {
@@ -26,6 +28,7 @@ prepare() {
cd "${srcdir}/${pkgname}"
git submodule init
git submodule update --recursive
+ patch -p0 < ../chdir.patch
}
package() {
diff --git a/chdir.patch b/chdir.patch
new file mode 100644
index 000000000000..d905d70d45f8
--- /dev/null
+++ b/chdir.patch
@@ -0,0 +1,17 @@
+--- mitmf.py 2015-12-10 21:33:55.685686688 +0100
++++ mitmf.py 2015-12-10 21:34:13.124298820 +0100
+@@ -25,6 +25,7 @@
+ import argparse
+ import sys
+ import os
++os.chdir("/opt/MITMf")
+ import threading
+ import core.responder.settings as settings
+
+@@ -179,4 +180,4 @@
+ reactor.run()
+ print "\n"
+
+- shutdown()
+\ No newline at end of file
++ shutdown()