summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-11-19 00:16:28 +0100
committerbartus2019-11-19 00:16:28 +0100
commit00b56a5e0fd5079f03a11dbc8e49b25ff5e45c81 (patch)
tree74ab97604eb7edb7103515d1b9606305182f3c77
parent91a35b9bf72610f4c11a7cef366e1c34ea68d66d (diff)
downloadaur-00b56a5e0fd5079f03a11dbc8e49b25ff5e45c81.tar.gz
Update Scons patch for pyton3.8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--python3.5.patch13
-rw-r--r--python3.8.patch26
4 files changed, 31 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 297bf4fa3285..7a538a69f7bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,9 +26,9 @@ pkgbase = mitsuba-git
conflicts = mitsuba
conflicts = mitsuba-hg
source = mitsuba::git+https://github.com/mitsuba-renderer/mitsuba.git
- source = python3.5.patch
+ source = python3.8.patch
sha256sums = SKIP
- sha256sums = 0591c38be9343db62d4f8294116f38cc836d170a5504cf2d70e472c48e290121
+ sha256sums = e3411c523aa56e1d784b64699cc32eaffc970b8e4d9645911e335e765fe472b4
pkgname = mitsuba-git
diff --git a/PKGBUILD b/PKGBUILD
index d9fba005b5fb..b0d9829d1eef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,10 +15,10 @@ makedepends=("eigen" "python2-scons" "git" "boost")
provides=("mitsuba")
conflicts=("mitsuba" "mitsuba-hg")
source=("${_pkgname}::git+https://github.com/mitsuba-renderer/mitsuba.git"
- "python3.5.patch"
+ "python3.8.patch"
)
sha256sums=('SKIP'
- '0591c38be9343db62d4f8294116f38cc836d170a5504cf2d70e472c48e290121')
+ 'e3411c523aa56e1d784b64699cc32eaffc970b8e4d9645911e335e765fe472b4')
pkgver() {
cd ${_pkgname}
@@ -55,7 +55,7 @@ prepare() {
sed -i "s/^CFLAGS[ ]*= \[/&\'${CFLAGS// /\',\'}\', /g" config.py
sed -i "s/^CXXFLAGS[ ]*= \[/&\'${CXXFLAGS// /\',\'}\', /g" config.py
- git apply ${srcdir}/python3.5.patch
+ git apply ${srcdir}/python3.8.patch
}
build() {
diff --git a/python3.5.patch b/python3.5.patch
deleted file mode 100644
index ca457a0dd49a..000000000000
--- a/python3.5.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/data/scons/detect_python.py b/data/scons/detect_python.py
-index 39ac04c..e24f28c 100644
---- a/data/scons/detect_python.py
-+++ b/data/scons/detect_python.py
-@@ -57,7 +57,7 @@ def find_boost_python(version):
- return None
-
- def detect_python():
-- pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6']
-+ pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6', '3.7']
- pyenv = {}
-
- for version in pyver:
diff --git a/python3.8.patch b/python3.8.patch
new file mode 100644
index 000000000000..598e951f60fa
--- /dev/null
+++ b/python3.8.patch
@@ -0,0 +1,26 @@
+diff --git a/build/SConscript.configure b/build/SConscript.configure
+index fe9a2502..af9d2592 100644
+--- a/build/SConscript.configure
++++ b/build/SConscript.configure
+@@ -30,7 +30,7 @@ if needsBuildDependencies and not os.path.exists(GetBuildPath('#dependencies')):
+ print 'at http://www.mitsuba-renderer.org/docs.html for details on how to get them.\n'
+ Exit(1)
+
+-python_versions = ["2.6", "2.7", "3.0", "3.1", "3.2", "3.3", "3.4", "3.5", "3.6", "3.7"]
++python_versions = ["2.6", "2.7", "3.0", "3.1", "3.2", "3.3", "3.4", "3.5", "3.6", "3.7", "3.8"]
+
+ # Parse configuration options
+ vars = Variables(configFile)
+diff --git a/data/scons/detect_python.py b/data/scons/detect_python.py
+index f2c9fa33..42b6829c 100644
+--- a/data/scons/detect_python.py
++++ b/data/scons/detect_python.py
+@@ -57,7 +57,7 @@ def find_boost_python(version):
+ return None
+
+ def detect_python():
+- pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6']
++ pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6', '3.7', '3.8']
+ pyenv = {}
+
+ for version in pyver: