summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-12-04 11:05:48 +0100
committerbartus2020-12-04 11:07:41 +0100
commit8275cb41916fe9e3ff52af6071ed1bed900e6a95 (patch)
treea6abc777cbfd4e56e75840a6e8bff78e7c1b63cb
parente15e24cb500e801c9c25b806a05db29dcca24fde (diff)
downloadaur-8275cb41916fe9e3ff52af6071ed1bed900e6a95.tar.gz
Update python:3.9
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--python3.9.patch (renamed from python3.8.patch)4
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a963e66f692..b0e3da24fb96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mitsuba-git
pkgdesc = Mitsuba physically based renderer.
- pkgver = 0.6.0.r2171.26355676
- pkgrel = 2
+ pkgver = 0.6.0.r2172.cfeb7766
+ pkgrel = 1
url = http://mitsuba-renderer.org/
arch = i686
arch = x86_64
@@ -26,9 +26,9 @@ pkgbase = mitsuba-git
conflicts = mitsuba
conflicts = mitsuba-hg
source = mitsuba::git+https://github.com/mitsuba-renderer/mitsuba.git
- source = python3.8.patch
+ source = python3.9.patch
sha256sums = SKIP
- sha256sums = e3411c523aa56e1d784b64699cc32eaffc970b8e4d9645911e335e765fe472b4
+ sha256sums = 6fc5513d95182a84209b4bbdce8cd2eee3bdf25aadd5da35c6b246479c4c8939
pkgname = mitsuba-git
diff --git a/PKGBUILD b/PKGBUILD
index 7455475906a2..8fef9f689b53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname="mitsuba"
_pkgver="0.6.0"
pkgname="${_pkgname}-git"
-pkgver=0.6.0.r2171.26355676
-pkgrel=2
+pkgver=0.6.0.r2172.cfeb7766
+pkgrel=1
pkgdesc="Mitsuba physically based renderer."
url="http://mitsuba-renderer.org/"
license=("GPL3")
@@ -15,10 +15,10 @@ makedepends=("eigen" "python2-scons" "git" "boost")
provides=("mitsuba")
conflicts=("mitsuba" "mitsuba-hg")
source=("${_pkgname}::git+https://github.com/mitsuba-renderer/mitsuba.git"
- "python3.8.patch"
+ "python3.9.patch"
)
sha256sums=('SKIP'
- 'e3411c523aa56e1d784b64699cc32eaffc970b8e4d9645911e335e765fe472b4')
+ '6fc5513d95182a84209b4bbdce8cd2eee3bdf25aadd5da35c6b246479c4c8939')
pkgver() {
cd ${_pkgname}
@@ -55,7 +55,7 @@ prepare() {
sed -i "s/^CFLAGS[ ]*= \[/&\'${CFLAGS// /\',\'}\', /g" config.py
sed -i "s/^CXXFLAGS[ ]*= \[/&\'${CXXFLAGS// /\',\'}\', /g" config.py
- git apply ${srcdir}/python3.8.patch
+ git apply ${srcdir}/python3.9.patch
}
build() {
diff --git a/python3.8.patch b/python3.9.patch
index 598e951f60fa..432c17331716 100644
--- a/python3.8.patch
+++ b/python3.9.patch
@@ -7,7 +7,7 @@ index fe9a2502..af9d2592 100644
Exit(1)
-python_versions = ["2.6", "2.7", "3.0", "3.1", "3.2", "3.3", "3.4", "3.5", "3.6", "3.7"]
-+python_versions = ["2.6", "2.7", "3.0", "3.1", "3.2", "3.3", "3.4", "3.5", "3.6", "3.7", "3.8"]
++python_versions = ["2.6", "2.7", "3.0", "3.1", "3.2", "3.3", "3.4", "3.5", "3.6", "3.7", "3.8", "3.9"]
# Parse configuration options
vars = Variables(configFile)
@@ -20,7 +20,7 @@ index f2c9fa33..42b6829c 100644
def detect_python():
- pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6']
-+ pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6', '3.7', '3.8']
++ pyver = ['2.6', '2.7', '3.0', '3.1', '3.2', '3.3', '3.4', '3.5', '3.6', '3.7', '3.8', '3.9']
pyenv = {}
for version in pyver: