summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-06-17 14:43:28 +0200
committerbartus2021-06-17 14:43:28 +0200
commit854fb94d131b3aa5a1eb220520620d8c64083725 (patch)
treee087bd003c26a67476fdf405e3af6878871cb8c2
parentd52794cae4998f73b6e657d421678af52536f7b0 (diff)
downloadaur-854fb94d131b3aa5a1eb220520620d8c64083725.tar.gz
Fix openexr:v3, fix gcc:11 defaulting to c++17
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 180ac29ef3f4..990f363ccbd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mitsuba-git
pkgdesc = Mitsuba physically based renderer.
pkgver = 0.6.0.r2172.cfeb7766
- pkgrel = 2
+ pkgrel = 3
url = http://mitsuba-renderer.org/
arch = i686
arch = x86_64
@@ -36,4 +36,3 @@ pkgbase = mitsuba-git
sha256sums = c4c571653c86e7c21d702f1f5cb9695edc32bf9fc05f6246e67a660693a32322
pkgname = mitsuba-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9149021d327b..6cb3a8887d43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname="mitsuba"
_pkgver="0.6.0"
pkgname="${_pkgname}-git"
pkgver=0.6.0.r2172.cfeb7766
-pkgrel=2
+pkgrel=3
pkgdesc="Mitsuba physically based renderer."
url="http://mitsuba-renderer.org/"
license=("GPL3")
@@ -53,10 +53,14 @@ prepare() {
# Scons doesn't honor environment variables
# user has to export then manually in Sconscript file.
+ export CXXFLAGS+=" -std=gnu++14"
sed -E -i "s/^(SH)?LINKFLAGS[ ]*= \[/&\'${LDFLAGS}\', /g" config.py
sed -i "s/^CFLAGS[ ]*= \[/&\'${CFLAGS// /\',\'}\', /g" config.py
sed -i "s/^CXXFLAGS[ ]*= \[/&\'${CXXFLAGS// /\',\'}\', /g" config.py
+ # Fix openexr:v3
+ sed -i "s/^OEXRLIB.*/OEXRLIB = ['OpenEXR']/g" config.py
+
git apply -v ${srcdir}/{python3.9,boost_107400}.patch
}