summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Hirzel2022-06-27 17:24:44 -0400
committerAlex Hirzel2022-06-27 17:40:04 -0400
commit2d5c886c37bb928dd828d68c67331ad22c814fef (patch)
tree142d26c32eb943f9d3e50a573ec6391380d3ec69
parent62fb6cfa41e02821279f380c031a40b36c9c58f3 (diff)
downloadaur-2d5c886c37bb928dd828d68c67331ad22c814fef.tar.gz
pull down nanogui for when it is needed
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3dea1e9ddd7..a8aae07019f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mitsuba2-git
pkgdesc = A Retargetable Forward and Inverse Renderer
- pkgver = 2.2.1.r38.g4e7628c6
- pkgrel = 3
+ pkgver = 2.2.1.r39.g83d1b180
+ pkgrel = 1
url = https://www.mitsuba-renderer.org/
arch = x86_64
license = custom
@@ -32,6 +32,7 @@ pkgbase = mitsuba2-git
source = git+https://github.com/wjakob/tbb.git
source = git+https://github.com/mitsuba-renderer/asmjit.git
source = git+https://github.com/mitsuba-renderer/enoki.git
+ source = git+https://github.com/mitsuba-renderer/nanogui.git
source = git+https://github.com/mitsuba-renderer/tinyformat.git
source = git+https://github.com/mitsuba-renderer/mitsuba-data.git
source = git+https://github.com/mitsuba-renderer/openexr.git
@@ -47,5 +48,6 @@ pkgbase = mitsuba2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = mitsuba2-git
diff --git a/.gitignore b/.gitignore
index 64b1d4a54847..65f6bcf6daa9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -10,6 +10,7 @@ asmjit/
enoki/
mitsuba-data/
mitsuba2/
+nanogui/
openexr/
tbb/
tinyformat/
diff --git a/PKGBUILD b/PKGBUILD
index 660701bb3a4e..7bb18f4f7bf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alex Hirzel <alex at hirzel period us>
pkgname=mitsuba2-git
-pkgver=2.2.1.r38.g4e7628c6
-pkgrel=3
+pkgver=2.2.1.r39.g83d1b180
+pkgrel=1
pkgdesc="A Retargetable Forward and Inverse Renderer"
arch=('x86_64')
url="https://www.mitsuba-renderer.org/"
@@ -21,6 +21,7 @@ source=('swap_pybind.patch'
'git+https://github.com/wjakob/tbb.git'
'git+https://github.com/mitsuba-renderer/asmjit.git'
'git+https://github.com/mitsuba-renderer/enoki.git'
+ 'git+https://github.com/mitsuba-renderer/nanogui.git'
'git+https://github.com/mitsuba-renderer/tinyformat.git'
'git+https://github.com/mitsuba-renderer/mitsuba-data.git'
'git+https://github.com/mitsuba-renderer/openexr.git')
@@ -35,6 +36,7 @@ md5sums=('e40fe4bf313d60b1eb7c3da60fb6d434'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -48,11 +50,12 @@ prepare() {
# mitsuba itself so that ABIs line up
git config submodule.ext/asmjit.url $srcdir/asmjit
git config submodule.ext/enoki.url $srcdir/enoki
+ git config submodule.ext/nanogui.url $srcdir/nanogui # provides bin2c
git config submodule.ext/tbb.url $srcdir/tbb
git config submodule.ext/tinyformat.url $srcdir/tinyformat
git config submodule.ext/openexr.url $srcdir/openexr
git config submodule.resources/data.url $srcdir/mitsuba-data
- git submodule update --init ext/asmjit ext/enoki ext/tbb ext/tinyformat ext/openexr resources/data
+ git submodule update --init ext/asmjit ext/enoki ext/nanogui ext/tbb ext/tinyformat ext/openexr resources/data
# system versions of these modules are used
rmdir ext/zlib ext/libpng ext/libjpeg
@@ -67,7 +70,7 @@ prepare() {
git apply -v $srcdir/python_collections.patch
# not used with the current build options
- rmdir ext/embree ext/nanogui
+ rmdir ext/embree
# generate the mitsuba.conf file with only one renderer (RGB)
# NOTE: change this if you want to build something else