summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-03-01 11:40:14 +0100
committerbartus2021-03-01 11:40:14 +0100
commit9ad0f4280ce9d59e3bad6c340e7cf0e8e9c37e43 (patch)
tree3375c1ea97d2de2e34adf28a6a67d016f3534f0d
parent214c1f0d96c8e33697a3f036827ea503c29d60d7 (diff)
downloadaur-9ad0f4280ce9d59e3bad6c340e7cf0e8e9c37e43.tar.gz
Fix build against Sphinx:3.5.1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--sphinx_351.patch20
3 files changed, 29 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b5d48921ff9..b12fe83586b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,6 +34,7 @@ pkgbase = mitsuba2-git
source = git+https://github.com/mitsuba-renderer/tinyformat.git
source = git+https://github.com/mitsuba-renderer/mitsuba-data.git
source = git+https://github.com/mitsuba-renderer/openexr.git
+ source = sphinx_351.patch
md5sums = e40fe4bf313d60b1eb7c3da60fb6d434
md5sums = 617bd32eecbebd8c7036f738b8275e5f
md5sums = 3d896789646b5de546668d9f158697d1
@@ -44,6 +45,7 @@ pkgbase = mitsuba2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 24fbc6bf556cfc5a67a759abfec3c8c7
pkgname = mitsuba2-git
diff --git a/PKGBUILD b/PKGBUILD
index 2cbe8ff768c6..dac2cbdb8688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,8 @@ source=('swap_pybind.patch'
'git+https://github.com/mitsuba-renderer/enoki.git'
'git+https://github.com/mitsuba-renderer/tinyformat.git'
'git+https://github.com/mitsuba-renderer/mitsuba-data.git'
- 'git+https://github.com/mitsuba-renderer/openexr.git')
+ 'git+https://github.com/mitsuba-renderer/openexr.git'
+ 'sphinx_351.patch')
md5sums=('e40fe4bf313d60b1eb7c3da60fb6d434'
'617bd32eecbebd8c7036f738b8275e5f'
'3d896789646b5de546668d9f158697d1'
@@ -31,7 +32,8 @@ md5sums=('e40fe4bf313d60b1eb7c3da60fb6d434'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '24fbc6bf556cfc5a67a759abfec3c8c7')
pkgver() {
git -C "$srcdir/${pkgname%-git}" describe --long --tags --always | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
@@ -68,6 +70,9 @@ prepare() {
| jq '.["enabled"] = ["scalar_rgb"]' \
| jq '.["default"] = "scalar_rgb"' \
> "$srcdir/${pkgname%-git}"/mitsuba.conf
+
+ # fix sphinx:3.5.1 build
+ git apply -v "$srcdir"/sphinx_351.patch
}
build() {
diff --git a/sphinx_351.patch b/sphinx_351.patch
new file mode 100644
index 000000000000..547808a9ae6b
--- /dev/null
+++ b/sphinx_351.patch
@@ -0,0 +1,20 @@
+diff --git a/docs/conf.py b/docs/conf.py
+index d55711a2..fe409f71 100644
+--- a/docs/conf.py
++++ b/docs/conf.py
+@@ -164,6 +164,9 @@ todo_include_todos = True
+
+ extensions.append('sphinxcontrib.bibtex')
+
++# Add bibfile
++bibtex_bibfiles = ['references.bib']
++
+ # Touch the bibliography file to force a rebuild of it
+ Path('zz_bibliography.rst').touch()
+
+@@ -370,4 +373,4 @@ def custom_step(app):
+ def setup(app):
+ # Texinfo
+ app.connect("builder-inited", custom_step)
+- app.add_stylesheet('theme_overrides.css')
++ app.add_css_file('theme_overrides.css')