summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Hirzel2022-05-31 04:42:03 -0400
committerAlex Hirzel2022-05-31 05:03:18 -0400
commita4ae05e6635b4e01d07281c0bcd2efa6c3626365 (patch)
tree8aa375b45f9624cf80f3cba039fed8fc5ff05f50
parente7ec0d0b108d7a8aa5d6d6685b471e8ddfd20091 (diff)
downloadaur-a4ae05e6635b4e01d07281c0bcd2efa6c3626365.tar.gz
fix build of Python documentation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rw-r--r--python_collections.patch26
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4166b8b7681..cf23e4e86390 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,6 +26,7 @@ pkgbase = mitsuba2-git
source = swap_pybind.patch
source = swap_pugixml.patch
source = swap_pybind_enoki.patch
+ source = python_collections.patch
source = git+https://github.com/mitsuba-renderer/mitsuba2.git
source = git+https://github.com/wjakob/tbb.git
source = git+https://github.com/mitsuba-renderer/asmjit.git
@@ -36,6 +37,7 @@ pkgbase = mitsuba2-git
md5sums = e40fe4bf313d60b1eb7c3da60fb6d434
md5sums = 617bd32eecbebd8c7036f738b8275e5f
md5sums = eee8327568bbe7e0fa0a8d873eb2dea0
+ md5sums = fcd771afe770b24492938482d6facfed
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8cdfdb77ed3a..539d0a16f69c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,7 @@ install=
source=('swap_pybind.patch'
'swap_pugixml.patch'
'swap_pybind_enoki.patch'
+ 'python_collections.patch'
'git+https://github.com/mitsuba-renderer/mitsuba2.git'
'git+https://github.com/wjakob/tbb.git'
'git+https://github.com/mitsuba-renderer/asmjit.git'
@@ -25,6 +26,7 @@ source=('swap_pybind.patch'
md5sums=('e40fe4bf313d60b1eb7c3da60fb6d434'
'617bd32eecbebd8c7036f738b8275e5f'
'eee8327568bbe7e0fa0a8d873eb2dea0'
+ 'fcd771afe770b24492938482d6facfed'
'SKIP'
'SKIP'
'SKIP'
@@ -59,6 +61,9 @@ prepare() {
git apply -v $srcdir/swap_pugixml.patch
git -C ext/enoki apply -v $srcdir/swap_pybind_enoki.patch
+ # fix Python documentation
+ git apply -v $srcdir/python_collections.patch
+
# not used with the current build options
rmdir ext/embree ext/nanogui
diff --git a/python_collections.patch b/python_collections.patch
new file mode 100644
index 000000000000..4515a328ab02
--- /dev/null
+++ b/python_collections.patch
@@ -0,0 +1,26 @@
+diff --git a/docs/exts/sphinxtr/custombackports.py b/docs/exts/sphinxtr/custombackports.py
+index 8741cd1f..a2657d2d 100644
+--- a/docs/exts/sphinxtr/custombackports.py
++++ b/docs/exts/sphinxtr/custombackports.py
+@@ -1,9 +1,11 @@
+ import collections
+
++collections_abc = getattr(collections, 'abc', collections)
++
+ Set = set
+
+ try:
+- from collections import OrderedDict
++ from collections_abc import OrderedDict
+ except ImportError:
+ class OrderedDict(dict):
+ 'Dictionary that remembers insertion order'
+@@ -252,7 +254,7 @@ except ImportError:
+
+ KEY, PREV, NEXT = range(3)
+
+-class OrderedSet(collections.MutableSet):
++class OrderedSet(collections_abc.MutableSet):
+ """
+ From: http://code.activestate.com/recipes/576694/
+ """