summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Hirzel2022-05-31 04:41:17 -0400
committerAlex Hirzel2022-05-31 05:03:08 -0400
commite7ec0d0b108d7a8aa5d6d6685b471e8ddfd20091 (patch)
treee13e5e873f8ab9cb7e717b367935042bba7dafd9
parent55080cba2b08f775178f79347cbe9729dd1add03 (diff)
downloadaur-e7ec0d0b108d7a8aa5d6d6685b471e8ddfd20091.tar.gz
avoid build error with latest tbb
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--swap_tbb.patch75
3 files changed, 9 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f0ce476b11..b4166b8b7681 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mitsuba2-git
pkgdesc = A Retargetable Forward and Inverse Renderer
- pkgver = 2.2.1.r33.g71dc35da
+ pkgver = 2.2.1.r38.g4e7628c6
pkgrel = 1
url = https://www.mitsuba-renderer.org/
arch = x86_64
@@ -23,12 +23,11 @@ pkgbase = mitsuba2-git
depends = libc++
depends = pybind11
depends = pugixml
- depends = tbb
source = swap_pybind.patch
source = swap_pugixml.patch
- source = swap_tbb.patch
source = swap_pybind_enoki.patch
source = git+https://github.com/mitsuba-renderer/mitsuba2.git
+ source = git+https://github.com/wjakob/tbb.git
source = git+https://github.com/mitsuba-renderer/asmjit.git
source = git+https://github.com/mitsuba-renderer/enoki.git
source = git+https://github.com/mitsuba-renderer/tinyformat.git
@@ -36,7 +35,6 @@ pkgbase = mitsuba2-git
source = git+https://github.com/mitsuba-renderer/openexr.git
md5sums = e40fe4bf313d60b1eb7c3da60fb6d434
md5sums = 617bd32eecbebd8c7036f738b8275e5f
- md5sums = 3d896789646b5de546668d9f158697d1
md5sums = eee8327568bbe7e0fa0a8d873eb2dea0
md5sums = SKIP
md5sums = SKIP
@@ -44,5 +42,6 @@ pkgbase = mitsuba2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = mitsuba2-git
diff --git a/PKGBUILD b/PKGBUILD
index 2608c27b7026..8cdfdb77ed3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Alex Hirzel <alex at hirzel period us>
pkgname=mitsuba2-git
-pkgver=2.2.1.r33.g71dc35da
+pkgver=2.2.1.r38.g4e7628c6
pkgrel=1
pkgdesc="A Retargetable Forward and Inverse Renderer"
arch=('x86_64')
url="https://www.mitsuba-renderer.org/"
license=('custom')
groups=()
-depends=('libpng' 'libjpeg-turbo' 'libc++' 'pybind11' 'pugixml' 'tbb')
+depends=('libpng' 'libjpeg-turbo' 'libc++' 'pybind11' 'pugixml')
makedepends=('clang' 'git' 'cmake' 'ninja' 'patchelf' 'python' 'python-sphinx' 'python-guzzle-sphinx-theme' 'python-sphinxcontrib-bibtex' 'jq')
checkdepends=('python-pytest' 'python-pytest-xdist' 'python-numpy')
install=
source=('swap_pybind.patch'
'swap_pugixml.patch'
- 'swap_tbb.patch'
'swap_pybind_enoki.patch'
'git+https://github.com/mitsuba-renderer/mitsuba2.git'
+ 'git+https://github.com/wjakob/tbb.git'
'git+https://github.com/mitsuba-renderer/asmjit.git'
'git+https://github.com/mitsuba-renderer/enoki.git'
'git+https://github.com/mitsuba-renderer/tinyformat.git'
@@ -24,13 +24,13 @@ source=('swap_pybind.patch'
'git+https://github.com/mitsuba-renderer/openexr.git')
md5sums=('e40fe4bf313d60b1eb7c3da60fb6d434'
'617bd32eecbebd8c7036f738b8275e5f'
- '3d896789646b5de546668d9f158697d1'
'eee8327568bbe7e0fa0a8d873eb2dea0'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -44,10 +44,11 @@ prepare() {
# mitsuba itself so that ABIs line up
git config submodule.ext/asmjit.url $srcdir/asmjit
git config submodule.ext/enoki.url $srcdir/enoki
+ git config submodule.ext/tbb.url $srcdir/tbb
git config submodule.ext/tinyformat.url $srcdir/tinyformat
git config submodule.ext/openexr.url $srcdir/openexr
git config submodule.resources/data.url $srcdir/mitsuba-data
- git submodule update --init ext/asmjit ext/enoki ext/tinyformat ext/openexr resources/data
+ git submodule update --init ext/asmjit ext/enoki ext/tbb ext/tinyformat ext/openexr resources/data
# system versions of these modules are used
rmdir ext/zlib ext/libpng ext/libjpeg
@@ -56,7 +57,6 @@ prepare() {
rmdir ext/pugixml ext/pybind11
git apply -v $srcdir/swap_pybind.patch
git apply -v $srcdir/swap_pugixml.patch
- git apply -v $srcdir/swap_tbb.patch
git -C ext/enoki apply -v $srcdir/swap_pybind_enoki.patch
# not used with the current build options
diff --git a/swap_tbb.patch b/swap_tbb.patch
deleted file mode 100644
index 7241236215fb..000000000000
--- a/swap_tbb.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-diff --git a/ext/CMakeLists.txt b/ext/CMakeLists.txt
-index 68bdee95..f97146d4 100644
---- a/ext/CMakeLists.txt
-+++ b/ext/CMakeLists.txt
-@@ -175,15 +175,7 @@ set(OPENEXR_INCLUDE_DIRS
- set(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
-
- # Build Thread Building Blocks (main shared libraries only)
--set(TBB_BUILD_SHARED ON CACHE BOOL " " FORCE)
--set(TBB_BUILD_STATIC OFF CACHE BOOL " " FORCE)
--set(TBB_BUILD_TESTS OFF CACHE BOOL " " FORCE)
--set(TBB_BUILD_TBBMALLOC OFF CACHE BOOL " " FORCE)
--set(TBB_BUILD_TBBMALLOC_PROXY OFF CACHE BOOL " " FORCE)
--add_subdirectory(tbb)
--set_property(TARGET tbb tbb_def_files PROPERTY FOLDER "dependencies")
--set(TBB_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/tbb/include)
--set(TBB_INCLUDE_DIRS ${TBB_INCLUDE_DIRS} PARENT_SCOPE)
-+find_package(TBB CONFIG)
-
- if (MTS_ENABLE_GUI)
- set_property(TARGET glfw glfw_objects nanogui nanogui-obj PROPERTY FOLDER "dependencies")
-diff --git a/src/libcore/CMakeLists.txt b/src/libcore/CMakeLists.txt
-index 40e461f5..b3fd8383 100644
---- a/src/libcore/CMakeLists.txt
-+++ b/src/libcore/CMakeLists.txt
-@@ -86,11 +86,6 @@ target_link_libraries(mitsuba-core PRIVATE
- # Image libraries: link to libjpeg, libpng, OpenEXR
- ${PNG_LIBRARIES} ${JPEG_LIBRARIES} IlmImf
- )
--#
--if (UNIX AND NOT APPLE)
-- target_link_libraries(mitsuba-core PUBLIC
-- -Wl,-rpath-link=$<TARGET_FILE_DIR:tbb>)
--endif()
-
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86_64|AMD64")
- target_link_libraries(mitsuba-core PRIVATE asmjit)
-@@ -102,7 +97,7 @@ if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86_64|AMD64")
- endif()
-
- # Copy to 'dist' directory
--add_dist(mitsuba-core IlmThread Half Half Imath IlmImf Iex tbb)
-+add_dist(mitsuba-core IlmThread Half Half Imath IlmImf Iex)
-
- if (CMAKE_CXX_COMPILER_ID MATCHES "^(GNU)$")
- target_link_libraries(mitsuba-core PRIVATE -Wl,--no-undefined)
-diff --git a/ext/rgb2spec/CMakeLists.txt b/ext/rgb2spec/CMakeLists.txt
-index 601af55f..e9fe41b7 100644
---- a/ext/rgb2spec/CMakeLists.txt
-+++ b/ext/rgb2spec/CMakeLists.txt
-@@ -18,7 +18,7 @@ if (CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang|Intel")
- endif()
-
-
--if (TARGET tbb)
-+if (TBB_FOUND)
- add_definitions(-DRGB2SPEC_USE_TBB=1)
- include_directories(${TBB_INCLUDE_DIRS})
- else ()
-@@ -34,14 +34,8 @@ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
- add_executable(rgb2spec_opt rgb2spec_opt.cpp)
- add_library(rgb2spec STATIC rgb2spec.c)
-
--if (TARGET tbb)
-+if (TBB_FOUND)
- target_link_libraries(rgb2spec_opt PRIVATE tbb)
--
-- add_custom_command(TARGET rgb2spec_opt POST_BUILD
-- COMMAND ${CMAKE_COMMAND} -E copy_if_different
-- $<TARGET_FILE:tbb>
-- $<TARGET_FILE_DIR:rgb2spec_opt>
-- )
- endif()
-
- add_custom_command(