summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaltazár Radics2023-09-29 11:27:28 +0200
committerBaltazár Radics2023-09-29 11:27:28 +0200
commitde3a4312cf3a6517e440a26e3274457b1980557e (patch)
treeae08f027b218947b42a0f594396ea582da18a2df
downloadaur-de3a4312cf3a6517e440a26e3274457b1980557e.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--mixing-station-pc.desktop7
-rw-r--r--mixing-station-pc.pngbin0 -> 21448 bytes
-rw-r--r--mixing-station-pc.sh3
5 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50d4110eabba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mixing-station-pc-bin
+ pkgdesc = Remote control digital mixers
+ pkgver = 1.9.9
+ pkgrel = 1
+ url = https://mixingstation.app/
+ arch = any
+ license = unknown
+ depends = java-runtime
+ provides = mixing-station-pc
+ conflicts = mixing-station-pc
+ source = mixing-station-pc.zip::https://mixingstation.app/backend/api/web/download/update/mixing-station-pc/release
+ source = mixing-station-pc.desktop
+ source = mixing-station-pc.png
+ source = mixing-station-pc.sh
+ sha256sums = SKIP
+ sha256sums = 2f923b4a4d449e975bb4fa3fb6f8934df5eba9251a74f12932232f05d32bb1f6
+ sha256sums = 80e8008f52ddb51d3b069d5fb3aaebaef398d27a0224d60d31f3c03a796fd671
+ sha256sums = b93eaaea70843227d0116f276127dcab83d07c1eac69af1c5c9424e8c602f5a5
+
+pkgname = mixing-station-pc-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c730cec581fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Baltazár Radics <baltazar.radics@gmail.com>
+_pkgname=mixing-station-pc
+pkgname=$_pkgname-bin
+pkgver=1.9.9
+pkgrel=1
+pkgdesc='Remote control digital mixers'
+arch=(any)
+url=https://mixingstation.app/
+license=(unknown)
+groups=()
+depends=(java-runtime)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=(
+ $_pkgname.zip::https://mixingstation.app/backend/api/web/download/update/$_pkgname/release
+ $_pkgname.desktop
+ $_pkgname.png
+ $_pkgname.sh
+)
+sha256sums=(SKIP
+ '2f923b4a4d449e975bb4fa3fb6f8934df5eba9251a74f12932232f05d32bb1f6'
+ '80e8008f52ddb51d3b069d5fb3aaebaef398d27a0224d60d31f3c03a796fd671'
+ 'b93eaaea70843227d0116f276127dcab83d07c1eac69af1c5c9424e8c602f5a5')
+
+pkgver() {
+ jar xf mixing-station-pc.jar META-INF/MANIFEST.MF
+ sed -n 's/^Implementation-Version: //p' META-INF/MANIFEST.MF | tr -d '\r\n'
+}
+
+package() {
+ install -Dm644 $_pkgname.jar "$pkgdir"/usr/lib/$_pkgname.jar
+ install -Dm644 $_pkgname.desktop "$pkgdir"/usr/share/applications/$_pkgname.desktop
+ install -Dm644 $_pkgname.png "$pkgdir"/usr/share/icons/$_pkgname.png
+ install -Dm655 $_pkgname.sh "$pkgdir"/usr/bin/$_pkgname
+}
diff --git a/mixing-station-pc.desktop b/mixing-station-pc.desktop
new file mode 100644
index 000000000000..5de6dc5237dc
--- /dev/null
+++ b/mixing-station-pc.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Mixing Station for Desktop
+Exec=/usr/bin/mixing-station-pc
+Icon=mixing-station-pc
+Terminal=false
+Type=Application
+Categories=AudioVideo
diff --git a/mixing-station-pc.png b/mixing-station-pc.png
new file mode 100644
index 000000000000..2f39b01a36ba
--- /dev/null
+++ b/mixing-station-pc.png
Binary files differ
diff --git a/mixing-station-pc.sh b/mixing-station-pc.sh
new file mode 100644
index 000000000000..5effd50496a6
--- /dev/null
+++ b/mixing-station-pc.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec java -jar /usr/lib/mixing-station-pc.jar "$@"