summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052025-04-09 18:44:38 +0800
committerzxp198210052025-04-09 18:44:38 +0800
commit221af3912c5e3cbc88730740229ee9fbecd6430f (patch)
tree33c77a6e91ea9fdcc6a1cb9fd48baf98336702cc
parente82ccd958cab16b5a9d65f806c38eec1b455d486 (diff)
downloadaur-221af3912c5e3cbc88730740229ee9fbecd6430f.tar.gz
update to fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
-rw-r--r--mizar.sh2
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d33d78ed00a9..30a816690999 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mizar-bin
- pkgdesc = A TCP testing tool, immediately useful and intuitive to use right out of the box
+ pkgdesc = A TCP testing tool, immediately useful and intuitive to use right out of the box.(Prebuilt version.Use system-wide electron)
pkgver = 1.3.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/Fabio286/mizar
arch = x86_64
license = MIT
@@ -12,6 +12,6 @@ pkgbase = mizar-bin
source = mizar-1.3.0.AppImage::https://github.com/Fabio286/mizar/releases/download/v1.3.0/Mizar-1.3.0-linux_x86_64.AppImage
source = mizar.sh
sha256sums = c4cd133ba91a23666cc36abf1b26e4fbad1ac26c842f0039821c9f5483535799
- sha256sums = 2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051
+ sha256sums = 291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980
pkgname = mizar-bin
diff --git a/PKGBUILD b/PKGBUILD
index 785885adba8f..6004de02ae3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@ pkgname=mizar-bin
_pkgname=Mizar
pkgver=1.3.0
_electronversion=22
-pkgrel=4
-pkgdesc="A TCP testing tool, immediately useful and intuitive to use right out of the box"
+pkgrel=5
+pkgdesc="A TCP testing tool, immediately useful and intuitive to use right out of the box.(Prebuilt version.Use system-wide electron)"
arch=('x86_64')
url="https://github.com/Fabio286/mizar"
license=('MIT')
@@ -21,23 +21,25 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('c4cd133ba91a23666cc36abf1b26e4fbad1ac26c842f0039821c9f5483535799'
- '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
-build() {
- sed -e "s|@electronversion@|${_electronversion}|g" \
- -e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@runname@|app.asar|g" \
- -e "s|@cfgdirname@|${_pkgname}|g" \
- -e "s|@options@||g" \
- -i "${srcdir}/${pkgname%-bin}.sh"
- chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ '291f50480f5a61bc9c68db7d44cd0412071128706baa868a9cb854f8779a1980')
+prepare() {
+ sed -i -e "
+ s/@electronversion@/${_electronversion}/g
+ s/@appname@/${pkgname%-bin}/g
+ s/@runname@/app.asar/g
+ s/@cfgdirname@/${_pkgname}/g
+ s/@options@//g
+ " "${srcdir}/${pkgname%-bin}.sh"
+ chmod +x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed -i "s/AppRun --no-sandbox/${pkgname%-bin}/g" "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
- for _icons in 16x16 32x32 64x64 128x128 256x256;do
+ _icon_sizes=(16x16 32x32 64x64 128x128 256x256)
+ for _icons in "${_icon_sizes[@]}";do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
diff --git a/mizar.sh b/mizar.sh
index 4cfe3ac09dd8..40e422ca2ee7 100644
--- a/mizar.sh
+++ b/mizar.sh
@@ -21,7 +21,7 @@ if [[ -f "${_FLAGS_FILE}" ]]; then
fi
done < "${_FLAGS_FILE}"
fi
-cd "${_APPDIR}"
+cd "${_APPDIR}" || { echo "Failed to change directory to ${_APPDIR}"; exit 1; }
if [[ "${EUID}" -ne 0 ]] || [[ "${ELECTRON_RUN_AS_NODE}" ]]; then
exec electron@electronversion@ "${_RUNNAME}" ${_OPTIONS} "${_USER_FLAGS[@]}" "$@"
else