summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2018-10-13 22:14:46 -0400
committerDaniel M. Capella2018-10-13 22:14:46 -0400
commit7d29946d3928e6a10eccf724e9a76525d40d859c (patch)
tree0233caefbf493d274bad2979af0308b860797fd2
parent2862c81e259711c8249a3706d1c0c4d364e4a387 (diff)
downloadaur-7d29946d3928e6a10eccf724e9a76525d40d859c.tar.gz
Make PyChromecast an optdep
https://github.com/muammar/mkchromecast/issues/211
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad396267814e..f7f1290f07d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Oct 13 07:48:37 UTC 2018
+# Sun Oct 14 02:13:19 UTC 2018
pkgbase = mkchromecast
pkgdesc = Cast Audio/Video to your Google Cast and Sonos Devices
pkgver = 0.3.8.1
@@ -14,7 +14,6 @@ pkgbase = mkchromecast
depends = python-flask
depends = python-gobject
depends = python-psutil
- depends = python-pychromecast
depends = sox
depends = vorbis-tools
optdepends = alsa-utils: to cast with ALSA
@@ -22,12 +21,15 @@ pkgbase = mkchromecast
optdepends = gstreamer: for gstreamer backend
optdepends = pavucontrol: to cast with PulseAudio
optdepends = pulseaudio: to cast with PulseAudio
+ optdepends = python-pychromecast: Chromecast support
optdepends = python-pyqt5: system tray menu support
optdepends = python-soco: Sonos support
optdepends = youtube-dl: YouTube support
options = !strip
source = mkchromecast-0.3.8.1.tar.gz::https://github.com/muammar/mkchromecast/archive/0.3.8.1.tar.gz
+ source = pychromecast-optional.patch::https://github.com/muammar/mkchromecast/commit/0070f9f2b505f1c5a1b6d63324ff337f2de09860.patch
sha512sums = ee66450768f3221500f198bf618120f02b93108797209ca0d6c2be9f882eee36753d3e1038354e51b5d76d130c12d193c7d152b33f80776cb225347a3743f376
+ sha512sums = 2fa2fa3986075582ed7f1d881ec32660b97278e47afffadecbd7cfc1c58833a734f5a7d442d4699fc99582c00b18e3c43cf87f974c8a8ec3af4b8ebfea40435f
pkgname = mkchromecast
diff --git a/PKGBUILD b/PKGBUILD
index e76ecd18776b..7b16fc77827d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,19 +8,27 @@ arch=('any')
url=http://mkchromecast.com
license=('MIT')
depends=('faac' 'flac' 'lame' 'python-flask' 'python-gobject' 'python-psutil'
- 'python-pychromecast' 'sox' 'vorbis-tools')
+ 'sox' 'vorbis-tools')
makedepends=('python-setuptools')
optdepends=('alsa-utils: to cast with ALSA'
'ffmpeg: for ffmpeg backend and/or to cast with ALSA'
'gstreamer: for gstreamer backend'
'pavucontrol: to cast with PulseAudio'
'pulseaudio: to cast with PulseAudio'
+ 'python-pychromecast: Chromecast support'
'python-pyqt5: system tray menu support'
'python-soco: Sonos support'
'youtube-dl: YouTube support')
options=('!strip')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/muammar/$pkgname/archive/$pkgver.tar.gz")
-sha512sums=('ee66450768f3221500f198bf618120f02b93108797209ca0d6c2be9f882eee36753d3e1038354e51b5d76d130c12d193c7d152b33f80776cb225347a3743f376')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/muammar/$pkgname/archive/$pkgver.tar.gz"
+ 'pychromecast-optional.patch::https://github.com/muammar/mkchromecast/commit/0070f9f2b505f1c5a1b6d63324ff337f2de09860.patch')
+sha512sums=('ee66450768f3221500f198bf618120f02b93108797209ca0d6c2be9f882eee36753d3e1038354e51b5d76d130c12d193c7d152b33f80776cb225347a3743f376'
+ '2fa2fa3986075582ed7f1d881ec32660b97278e47afffadecbd7cfc1c58833a734f5a7d442d4699fc99582c00b18e3c43cf87f974c8a8ec3af4b8ebfea40435f')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i pychromecast-optional.patch
+}
package() {
cd $pkgname-$pkgver