summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2017-06-22 22:13:31 -0400
committerDaniel M. Capella2017-06-24 05:42:12 -0400
commit93315fb3fb53e634e689b36526ec8eb2c280d3f2 (patch)
tree2db9972ae1a60d739733656474bd0a5ffc210eb5
downloadaur-93315fb3fb53e634e689b36526ec8eb2c280d3f2.tar.gz
Initial commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD48
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6f9da89fcc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+# Generated by mksrcinfo v8
+# Sat Jun 24 09:03:10 UTC 2017
+pkgbase = mkchromecast
+ pkgdesc = Cast Audio/Video to your Google Cast and Sonos Devices
+ pkgver = 0.3.7.1
+ pkgrel = 1
+ url = http://mkchromecast.com
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = faac
+ depends = flac
+ depends = gi
+ depends = lame
+ depends = python-flask
+ depends = python-psutil
+ depends = python-pychromecast
+ depends = sox
+ depends = vorbis-tools
+ optdepends = alsa-utils: to cast with ALSA
+ optdepends = ffmpeg: for ffmpeg backend and/or to cast with ALSA
+ optdepends = gstreamer: for gstreamer backend
+ optdepends = nodejs: for node backend
+ optdepends = pavucontrol: to cast with PulseAudio
+ optdepends = pulseaudio: to cast with PulseAudio
+ optdepends = python-pyqt5: system tray menu support
+ optdepends = python-soco: Sonos support
+ optdepends = youtube-dl: YouTube support
+ options = !strip
+ source = mkchromecast-0.3.7.1.tar.gz::https://github.com/muammar/mkchromecast/archive/0.3.7.1.tar.gz
+ source = https://raw.githubusercontent.com/muammar/mkchromecast/8ec3f90c0f7231758fdddb704233db0edc8b8ef2/mkchromecast.desktop
+ source = https://raw.githubusercontent.com/muammar/mkchromecast/8ec3f90c0f7231758fdddb704233db0edc8b8ef2/man/mkchromecast.1
+ sha512sums = b2c0a5357915b66ff2fd9d0bf8d4e8f97e8d676de0ab4351235519b8df95b764e7adeecf5f8074ff2ead8f71c0cc3b260226113a4b1ae98f3263f657955bca6a
+ sha512sums = 7477ea47368d3105ef9e4ba6a44138d81bb494ae7f711e26626d3ecda740fb4d9805cc3dcedafa9aa4450d3be70ef2465ce9cc0cd5291ca94fa795a7c1537ab9
+ sha512sums = f3d3e391d6f45ee37bafc600699388c533e202a28a529d23f058e9177f0c830daa89802892707fda0ed14667fae4060b24c44157b35ee000943f8c3a683c7e3e
+
+pkgname = mkchromecast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94b601c4b0a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
+
+pkgname=mkchromecast
+pkgver=0.3.7.1
+pkgrel=1
+pkgdesc='Cast Audio/Video to your Google Cast and Sonos Devices'
+arch=('any')
+url="http://$pkgname.com"
+license=('MIT')
+depends=('faac' 'flac' 'gi' 'lame' 'python-flask' 'python-psutil'
+ 'python-pychromecast' 'sox' 'vorbis-tools')
+makedepends=('python-setuptools')
+optdepends=('alsa-utils: to cast with ALSA'
+ 'ffmpeg: for ffmpeg backend and/or to cast with ALSA'
+ 'gstreamer: for gstreamer backend'
+ 'nodejs: for node backend'
+ 'pavucontrol: to cast with PulseAudio'
+ 'pulseaudio: to cast with PulseAudio'
+ 'python-pyqt5: system tray menu support'
+ 'python-soco: Sonos support'
+ 'youtube-dl: YouTube support')
+options=('!strip')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/muammar/$pkgname/archive/$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/muammar/$pkgname/8ec3f90c0f7231758fdddb704233db0edc8b8ef2/"{$pkgname.desktop,man/$pkgname.1})
+sha512sums=('b2c0a5357915b66ff2fd9d0bf8d4e8f97e8d676de0ab4351235519b8df95b764e7adeecf5f8074ff2ead8f71c0cc3b260226113a4b1ae98f3263f657955bca6a'
+ '7477ea47368d3105ef9e4ba6a44138d81bb494ae7f711e26626d3ecda740fb4d9805cc3dcedafa9aa4450d3be70ef2465ce9cc0cd5291ca94fa795a7c1537ab9'
+ 'f3d3e391d6f45ee37bafc600699388c533e202a28a529d23f058e9177f0c830daa89802892707fda0ed14667fae4060b24c44157b35ee000943f8c3a683c7e3e')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i '170,171d' $pkgname/cast.py # Workaround minor TypeError exception
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -d "$pkgdir"/usr/bin
+ ln -s /usr/share/$pkgname/$pkgname.py "$pkgdir"/usr/bin/$pkgname
+
+ install -Dm755 $pkgname.py "$pkgdir"/usr/share/$pkgname/$pkgname.py
+ cp -a --parents images/google* $pkgname nodejs "$pkgdir"/usr/share/$pkgname
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 images/$pkgname.xpm "$pkgdir"/usr/share/pixmaps/$pkgname.xpm
+ install -Dm644 ../$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+# vim:set ts=2 sw=2 et: