summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgituser2024-04-15 22:53:46 +0200
committergituser2024-04-15 22:53:46 +0200
commit6dae8581391fcf514502c3be54ee1c0a4ddf67d4 (patch)
tree5b27c8ff33a50025cc643883ac8bfdc8d90bfdbb
downloadaur-6dae8581391fcf514502c3be54ee1c0a4ddf67d4.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63284022195e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mkchrootb
+ pkgdesc = chroot-only AUR helper written in bash
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kylon/mkchrootb
+ arch = any
+ license = GPL-3.0-or-later
+ depends = jq
+ optdepends = tig
+ optdepends = vifm
+ optdepends = nano
+ optdepends = vi
+ source = https://raw.githubusercontent.com/kylon/mkchrootb/c78c768049323352dd784768730b3d10e8d30d04/mkchrootb
+ sha256sums = d5ca1e848d35213c9a2d413d5949c7448c9af37443de4ab99d39b5ed08fa38c7
+
+pkgname = mkchrootb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28cdbfd80370
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: kylon < klnix [at] tuta [dt] io >
+pkgname='mkchrootb'
+pkgver=1.0
+pkgrel=1
+pkgdesc='chroot-only AUR helper written in bash'
+url='https://github.com/kylon/mkchrootb'
+arch=('any')
+sha256sums=('d5ca1e848d35213c9a2d413d5949c7448c9af37443de4ab99d39b5ed08fa38c7')
+license=('GPL-3.0-or-later')
+source=('https://raw.githubusercontent.com/kylon/mkchrootb/c78c768049323352dd784768730b3d10e8d30d04/mkchrootb')
+depends=('jq')
+optdepends=('tig' 'vifm' 'nano' 'vi')
+
+package() {
+ install -Dm755 "${srcdir}/mkchrootb" "${pkgdir}/usr/local/bin/${pkgname}"
+}