summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Update Bot2015-09-02 20:52:02 +0200
committerStefan Husmann2015-09-02 20:52:02 +0200
commit38f916f0ff90d02205f93d7bdf330c0e763b7cd0 (patch)
tree800aa1bd71237241d337eeca566be10723595e80
parent1450d74c3a3e3119c04519f560e6f8c69233c206 (diff)
downloadaur-38f916f0ff90d02205f93d7bdf330c0e763b7cd0.tar.gz
Updated version (1.1.9.97.ge4fe40c -> 1.1.9.99.g8ca4595).
Changelog ========= Fix reader usage in a few dispatch-macro-character readers. (8ca4595) Get rid of an SBCLism. (13070ec) Support VALUES form as place in macros cl:psetf, cl:shiftf and cl:rotatef. (e4fe40c) make compiler aware that #'cl:string is not a predicate. (50c665f) Make defstruct work even when not at top-level. (This fixes a long standing regression.) (37c658f) Complete initialization of newly created symbol. (0f0f5f1) Fix a few error message format strings. (70b5882) Type (array t 1) is now properly recognized as a valid sequence by #'si::closest-sequence-type. (7ca2805) Fix legacy optimizer for cl::mapcar et al. First argument now evaluated only once. (c5a7213) Fix generated copier for typed representation structures. (3db8e66) Muffle nagging spurious warnings occurring during shutdown. (14754ab) Add #'mkcl::file-character-position. (b864fe2) Handle condition signaled by ASDF3 on compilation error. (6d2f6eb) Improve a bit compilation error message layout. (9e7ae27) Proclaim signature for #'map and #'map-into. (f593b7f) Make compiler aware of user-level proclaim. (8d9b3a9) In defclass, improve processing of extra class options. (0155661) In defstruct, make :metaclass option somewhat more reliable. (d8d690d) Add #'si::undefine-symbol-macro. (120a33e) Comment out invalid proclaim for fmakunbound. (29d17b9) Adjust copyright period. (0d16cc4) Fix behavior of #'cl:probe-file et al. (6a25c58) Aftershock of previous commit. (fb2b696) Fix secondary values corruption in code generated for multiple-value-bind by our Lisp-to-C compiler. (11544ed) Fix implementation and support of swank-compile-string. (64c3770) ensure a bit more second return value of mkcl::run-program-1. (51dc5e6) Complete Gray stream integration. (7f05991) make explicit package reference for #'si::structure-type-error. (4ac65db) Fix C compiler optimization of funcall/apply of immediate lambda expressions. (7ac4fb0) Try to harden stack growth orientation detection. (da3a2f0) Improve #'cl:no-applicable-method default method and ensure its use. (169ed91) Try to contain dynamic-extent cons leak within one load unit. (9f3027e) Make warning on forward referenced classes opt-in. (2c7615d) Fix legacy screw-up on #'si::memq proclamation. (43a2f42) Bump copyright period for new year (2015). (1610a64) Rework #'si::hash-table-iterator and ancillaries to conform better to Traversal Rules (CLHS 3.6). (1a28321) Improve conformance of #'cl::maphash WRT to Traversal Rules (CLHS 3.6). (bc30ab7) Improve somewhat effective method cache hash function. (7ed7c97) Improve robustness of hash functions on recursive data. (533fc0d) Make si::copy-hash-table safer on Win64 for large hash-tables. (7eb5ecd) GF cache now handles properly a class object as EQL specializer. (3749dc7) Prevent possible out of range memory access. (60bcc30) Move useless pre-ECL (ECoLisp era) remnant to pasture. (f481393) Improve new handling of metaclass migration on class redefinition. (633ca14) On class redefinition, metaclass migration is not an error. (44d60e0) Fix cl:coerce and cl:concatenate to behave closer to ANSI spec when result-type is either cl:string or cl:base-string. (fa5c2a0) improve comments on circular list detection. (7a516de) Remove some recently commented out code. (7838a22) Make #'cl:clear-input handle end of file (EOF) properly on files. (ba2ef80) Regenerate configure script to force GC to use mmap(). (0f1e02e) Fix GC lockup on callback block recycling. (3b2cc5a) Ignore private receipe file for GC. (14dd197) Clean gc a bit more. (5d45d6c) Add a warning about dubious configuration on Linux. (c922842) Prevent sigsegv_handler from masking errors in protected foreign code. (d63df7e) Fix recently rewritten test on lambda-list length. (a75d055) Modernize detection of special attributes in clang. (b859863) Improve parsing of lambda lists in bytecode compiler. (4957059) Achieve clean compile with clang 3.3. (01cac48) Achieve clean compile with clang 3.0. (a27e0c1) Make better identification of classes and generic-functions. (8074799) Fix access to generic-function name in debugger. (bea4c90) Silence trivial warning. (fc48fe8) Make more explicit unit of field length in struct mkcl_instance. (84d6e69) Fix cut&paste accident. (aa2511b) Add #'clos::slot-exists-p-using-class since it is mentionned in ANSI-CL spec. (253b6f0) Win64 aftershock of the Grand shakedown for Coverity. With this we achieve a detected defect density of 0.00 on our C runtime code as included in mkclmin.a on Win64. (96338ec) Win32 aftershock of the Grand shakedown for Coverity. With this we achieve a detected defect density of 0.00 on our C runtime code as included in mkclmin.a on Win32. (5082f20) Grand shakedown for Coverity. With it we achieve a bug density of 0.01 on our C runtime as built for mkcl_min. (fab1598) Merge remote-tracking branch 'origin/master' (018e4c4) Correctly handle size of argument pathname buffer in 'dpp' utility. (92d68e7) Correctly handle size of argument pathname buffer size in 'dpp' utility. (b76e34a) In c-inline body string C escape backslashes must be doubled. (d0b6830) Fix cl:compute-restarts for regression introduced in 1.1.9. (b5ebcf8) Clarify error message. (447f41c) Typos. (d22bd88) 'make uninstall' now cleans dangling shared library links. (27c176f) Restore shared library prefix according to local convention. (5d99aa6) Ensure accessors are created at moment of class definition. (01d1822) 'make uninstall' now removes the executable properly. (a9cb426) Make superclass list of generic-function more ANSI-CL (and less AMOP). (6c9510f) Merge pull request #5 from abbrev/fix-uninstall (4f87c75) Fix 'make uninstall' shell commands. (8fe0051) Fix migration of shared slots accross class redefinition "in place". (9ca411a) Varia. (ba95a8f) Refactor a bit more last commit. (60d83b9) Refactor previous commit. (627bfff) Fix bug in #'cl:coerce on target-type list. (3457edb) Fix the object initialization protocol for shared slots. (d393346) Fix method signatures in the object initialization protocols. (109c09d) Improve handling of unfinalized classes in change-class and update-instance. Fix finalization of redefined classes. (d73cf8d) Fix a legacy goof. (75ca534) Reorganize slot accessors generation. (2f89fe8) Remove character name alias "Bell" since it may clash with Unicode U1F514. (e2cfb7a) Fix class redefinition semantics (take 2). (50900fa) Add qualifier to print representation of methods. (61381ed) Fix class redefinition semantics. (e79ee25) Class "sealing" needs to be redesigned! (e81954f) Initiate work on version 1.1.10. (c3c45e4)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cfdcb32f0a3..90b567f0e737 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkcl-git
pkgdesc = ManKai Common Lisp -- git-version
- pkgver = 1.1.9.97.ge4fe40c
+ pkgver = 1.1.9.99.g8ca4595
pkgrel = 1
url = http://common-lisp.net/project/mkcl/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 4d4cdade4f14..6939ae98dc40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=mkcl-git
-pkgver=1.1.9.97.ge4fe40c
+pkgver=1.1.9.99.g8ca4595
pkgrel=1
pkgdesc="ManKai Common Lisp -- git-version"
arch=('i686' 'x86_64')