summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn W. Burton2023-06-16 11:44:30 -0400
committerTarn W. Burton2023-06-16 11:44:30 -0400
commit9d96cc6aa92ed84464b3778096f287e9cbc230d1 (patch)
tree331a715fbd6420e7b30be2722907677d99d049ab
parent4865cb75a5b4c7d72da65f2b467ab68f4b5c737e (diff)
downloadaur-9d96cc6aa92ed84464b3778096f287e9cbc230d1.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 34 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0334e0a52475..e7e8314f1aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,18 @@
-# Generated by mksrcinfo v8
-# Tue Jul 25 20:36:02 UTC 2017
pkgbase = mkcl-git
- pkgdesc = ManKai Common Lisp -- git-version
- pkgver = 1.1.10.19.g2dbfa99
+ pkgdesc = ManKai Common Lisp
+ pkgver = v1.1.9.r515.g19222c1
pkgrel = 1
- url = http://common-lisp.net/project/mkcl/
- arch = i686
+ url = https://github.com/jcbeaudoin/MKCL
arch = x86_64
- license = LGPL3
- license = custom
+ license = LGPL
makedepends = git
- depends = gawk
+ depends = awk
+ depends = bash
+ depends = glibc
+ depends = gmp
provides = common-lisp
- provides = cl-asdf
- conflicts = mkcl
- options = staticlibs
- source = git+https://gitlab.common-lisp.net/mkcl/mkcl.git
- md5sums = SKIP
+ options = !strip
+ source = git+https://github.com/jcbeaudoin/MKCL.git
+ sha512sums = SKIP
pkgname = mkcl-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e58528c06dbb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*.tar.gz
+*.zst
+MKCL
diff --git a/PKGBUILD b/PKGBUILD
index 2d5ee365156c..e586fb203668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,31 @@
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Tarn W. Burton <twburton@gmail.com>
pkgname=mkcl-git
-pkgver=1.1.10.19.g2dbfa99
+pkgver=v1.1.9.r515.g19222c1
pkgrel=1
-pkgdesc="ManKai Common Lisp -- git-version"
-arch=('i686' 'x86_64')
-url="http://common-lisp.net/project/mkcl/"
-license=('LGPL3' 'custom')
-depends=('gawk')
+pkgdesc="ManKai Common Lisp"
+arch=('x86_64')
+url="https://github.com/jcbeaudoin/MKCL"
+license=('LGPL')
+options+=(!strip)
+depends=('awk' 'bash' 'glibc' 'gmp')
makedepends=('git')
-provides=('common-lisp' 'cl-asdf')
-conflicts=('mkcl')
-source=("git+https://gitlab.common-lisp.net/mkcl/mkcl.git")
-options=('staticlibs')
-md5sums=('SKIP')
+provides=('common-lisp')
+source=('git+https://github.com/jcbeaudoin/MKCL.git')
+sha512sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --tags | sed 's|-|.|g'|cut -c2-
+ cd MKCL
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname%-git}"
- ./configure --prefix=/usr
+ cd MKCL
+ ./configure --prefix=/usr
make
}
package() {
- cd "${pkgname%-git}"
- make prefix="$pkgdir/usr" install
- install -m 644 -D "Copyright" \
- "$pkgdir/usr/share/licenses/$pkgname/Copyright"
- find "$pkgdir" -name "*.a" -exec chmod 644 {} \;
+ cd MKCL
+ make DESTDIR=$pkgdir install
}
+