summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-09-17 19:58:29 +0200
committersL1pKn072017-09-17 19:58:29 +0200
commit03de8d837f8360e5c3534bb9ec98a3a2c8dac032 (patch)
treebde12e359736e1577b775e02e00622ba6db2581d
parente30aa4db2a7b34b5ea9baee16a43aa3d0869b11c (diff)
downloadaur-03de8d837f8360e5c3534bb9ec98a3a2c8dac032.tar.gz
Update to 0.8.10
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b573eeed05f..f7b44db3d93e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Sep 17 17:58:14 UTC 2017
pkgbase = mkclean
pkgdesc = Clean up and optimize MKV files
- pkgver = 0.8.7
- pkgrel = 6
+ pkgver = 0.8.10
+ pkgrel = 1
url = http://www.matroska.org/downloads/mkclean.html
arch = armv6h
arch = i686
arch = x86_64
license = BSD
options = !makeflags
- source = http://sourceforge.net/projects/matroska/files/mkclean/mkclean-0.8.7.tar.bz2
- sha1sums = 21d9dd829086fe13771815481b6c7beeb83aca88
+ source = http://sourceforge.net/projects/matroska/files/mkclean/mkclean-0.8.10.tar.bz2
+ sha256sums = 96773e72903b00d73e68ba9d5f19744a91ed46d27acd511a10eb23533589777d
pkgname = mkclean
diff --git a/PKGBUILD b/PKGBUILD
index 63bb6f684686..4a2a98d6044d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,33 @@
# Contributor: garion < garion @ mailoo.org >
pkgname=mkclean
-pkgver=0.8.7
-pkgrel=6
+pkgver=0.8.10
+pkgrel=1
pkgdesc="Clean up and optimize MKV files"
arch=('armv6h' 'i686' 'x86_64')
url='http://www.matroska.org/downloads/mkclean.html'
license=('BSD')
source=("http://sourceforge.net/projects/matroska/files/mkclean/mkclean-${pkgver}.tar.bz2")
-sha1sums=('21d9dd829086fe13771815481b6c7beeb83aca88')
+sha256sums=('96773e72903b00d73e68ba9d5f19744a91ed46d27acd511a10eb23533589777d')
options=('!makeflags')
prepare() {
cd "mkclean-${pkgver}"
- [ "${CARCH}" = "armv6h" ] && find ./corec/tools/coremake/ -type f -exec sed 's|arm-none-linux-gnueabi-||g' -i {} \;
- ./configure
- find . -name '*.mak' -exec sed "s|/usr/local|${pkgdir}/usr|g" -i {} \;
+ gcc ${CFAGS} -o coremake corec/tools/coremake/coremake.c
+
+ if [ "${CARCH}" = "i686" ]; then
+ _target="gcc_linux"
+ elif [ "${CARCH}" = "x86_64" ]; then
+ _target="gcc_linux_x64"
+ elif [ "${CARCH}" = "armv6h" ]; then
+ sed 's|arm-linux-gnueabi-||g' -i corec/tools/coremake/gcc_linux_arm
+ _target="gcc_linux_arm"
+ fi
+
+ sed "s|/usr/local|${pkgdir}/usr|g" -i corec/tools/coremake/gcc_mak.inc
+
+ ./coremake ${_target}
}
build(){