summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 18:35:17 +0200
committersl1pkn072015-06-08 18:35:17 +0200
commit65554276ff04251a968e22e9875ed114b05c1926 (patch)
tree044e936bd4be84b5d7163876c1a0e4be152f0273
downloadaur-65554276ff04251a968e22e9875ed114b05c1926.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d38006b3a78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = mkclean
+ pkgdesc = Clean up and optimize MKV files
+ pkgver = 0.8.7
+ pkgrel = 5
+ url = http://www.matroska.org/downloads/mkclean.html
+ arch = armv6h
+ arch = i686
+ arch = x86_64
+ license = BSD
+ options = !makeflags
+ source = http://sourceforge.net/projects/matroska/files/mkclean/mkclean-0.8.7.tar.bz2
+ sha1sums = 21d9dd829086fe13771815481b6c7beeb83aca88
+
+pkgname = mkclean
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98986fc8f36f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: garion < garion @ mailoo.org >
+
+pkgname=mkclean
+pkgver=0.8.7
+pkgrel=5
+pkgdesc="Clean up and optimize MKV files"
+arch=('armv6h' 'i686' 'x86_64')
+url="http://www.matroska.org/downloads/mkclean.html"
+license=('BSD')
+source=("http://sourceforge.net/projects/matroska/files/mkclean/mkclean-${pkgver}.tar.bz2")
+sha1sums=('21d9dd829086fe13771815481b6c7beeb83aca88')
+options=('!makeflags')
+
+prepare() {
+ cd "mkclean-${pkgver}"
+ [ "${CARCH}" = "armv6h" ] && find ./corec/tools/coremake/ -type f -exec sed 's|arm-none-linux-gnueabi-||g' -i {} \;
+ ./configure
+
+ find . -name '*.mak' -exec sed "s|/usr/local|${pkgdir}/usr|g" -i {} \;
+}
+
+build(){
+ cd "mkclean-${pkgver}/mkclean"
+ make
+}
+
+package(){
+ cd "mkclean-${pkgver}/mkclean"
+ mkdir -p "${pkgdir}/usr/bin"
+ make install
+}