summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Audet2015-06-08 20:33:38 -0400
committerJeremy Audet2015-06-08 20:33:38 -0400
commitd534346bdc01e3f02375b46c3bc98098403501ba (patch)
tree785de74e3d4655079ebe503b9ccb1c4d54160b0e
downloadaur-d534346bdc01e3f02375b46c3bc98098403501ba.tar.gz
Initial commit (version 3617)
Note that the version has little meaning, given that this is an SVN package.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD55
-rwxr-xr-xmkgmap2
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8623386df037
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mkgmap-svn
+ pkgdesc = Create maps for Garmin GPS devices from OpenStreetMap (OSM) data.
+ pkgver = 3617
+ pkgrel = 1
+ url = http://www.mkgmap.org.uk
+ arch = any
+ license = GPL2
+ makedepends = subversion
+ makedepends = apache-ant
+ depends = java-runtime
+ conflicts = mkgmap
+ source = mkgmap
+ source = svn+http://svn.mkgmap.org.uk/mkgmap/trunk
+ sha256sums = 135dfbca5146cea34ef48ed6908a817efdfbbcccbb8adfbbb6a100f58c2c7bb6
+ sha256sums = SKIP
+
+pkgname = mkgmap-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d31257a21450
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jeremy "Ichimonji10" Audet <ichimonji10 at gmail dot com>
+# Contributor: Gour <gour@atmarama.net>
+#
+# namcap warns that 'java-environment' is a dependency. This is untrue:
+# java-runtime suffices.
+#
+
+pkgname=mkgmap-svn
+_pkgname=mkgmap
+pkgver=3617
+pkgrel=1
+pkgdesc='Create maps for Garmin GPS devices from OpenStreetMap (OSM) data.'
+url='http://www.mkgmap.org.uk'
+license=(GPL2)
+arch=(any)
+depends=(java-runtime)
+makedepends=(subversion apache-ant)
+conflicts=("${_pkgname}")
+source=("${_pkgname}" "svn+http://svn.mkgmap.org.uk/${_pkgname}/trunk")
+sha256sums=('135dfbca5146cea34ef48ed6908a817efdfbbcccbb8adfbbb6a100f58c2c7bb6'
+ 'SKIP')
+
+pkgver() {
+ # -c makes svnversion show the version of "trunk", not the version of the
+ # repository as a whole. Unfortunately, -c also makes svnversion show the full
+ # range of revisions that comprise "trunk". For example:
+ #
+ # svnversion => 2756
+ # svnversion -c => 53:2754
+ #
+ # Use parameter expansion trickery to strip off the leading number and colon.
+ cd trunk
+ local readonly ver="$(svnversion -c)"
+ echo "${ver#*:}"
+}
+
+build() {
+ cd "${srcdir}/trunk"
+ ant
+}
+
+package() {
+ cd "${srcdir}/trunk/dist"
+
+ # Install the executable, jar file and man page.
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm644 "${_pkgname}.jar" \
+ "${pkgdir}/usr/share/java/${_pkgname}/${_pkgname}.jar"
+ install -Dm644 "doc/${_pkgname}.1" "${pkgdir}/usr/share/man/man1/${_pkgname}.1"
+
+ # Install libraries. Destination dir created when installing jar file.
+ cp -r lib/ "${pkgdir}/usr/share/java/${_pkgname}/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/mkgmap b/mkgmap
new file mode 100755
index 000000000000..914990de0940
--- /dev/null
+++ b/mkgmap
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+java -jar /usr/share/java/mkgmap/mkgmap.jar "$@"