summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Brand2019-02-25 18:49:13 +0000
committerSimon Brand2019-02-25 18:54:24 +0000
commitf85cf9b693bc0f858057d765c229a1b8ae0b0d0a (patch)
treea958a88ef8c0166badcb4b03e60918e788d698d4
downloadaur-f85cf9b693bc0f858057d765c229a1b8ae0b0d0a.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66f1e8e12872
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mkinitcpio-authentication
+ pkgdesc = mkinitcpio hook to enable authentication in initramfs
+ pkgver = 0.r1.be53c2b
+ pkgrel = 1
+ url = https://github.com/brandsimon/mkinitcpio-authentication
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = mkinitcpio
+ source = git+https://github.com/brandsimon/mkinitcpio-authentication.git
+ sha256sums = SKIP
+
+pkgname = mkinitcpio-authentication
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc424ab1ab2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: SimonBrand <simon.brand@postadigitale.de>
+pkgname=mkinitcpio-authentication
+pkgver=0.r1.be53c2b
+pkgrel=1
+pkgdesc="mkinitcpio hook to enable authentication in initramfs"
+arch=('any')
+url="https://github.com/brandsimon/mkinitcpio-authentication"
+license=('GPL')
+depends=('mkinitcpio')
+optdepends=()
+source=("git+https://github.com/brandsimon/mkinitcpio-authentication.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd mkinitcpio-authentication
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/mkinitcpio-authentication"
+ install -Dm644 authentication_install \
+ "${pkgdir}/usr/lib/initcpio/install/authentication"
+ install -Dm644 authentication_hook \
+ "${pkgdir}/usr/lib/initcpio/hooks/authentication"
+}