summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Maerz2019-02-24 03:31:19 +0100
committerRobert Maerz2019-02-24 03:31:19 +0100
commit88d2d0c562e1a354b367309cb99089c459dbbdeb (patch)
tree80aae416267cddecc89923dfedeb7bdb84953e26
downloadaur-88d2d0c562e1a354b367309cb99089c459dbbdeb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c80423c1cee5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mkinitcpio-bluetooth
+ pkgdesc = This is an initcpio hook for bluetooth connectivity during boot / in initramfs.
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/irreleph4nt/mkinitcpio-bluetooth/
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ makedepends = git
+ depends = bluez
+ depends = bluez-utils
+ depends = dbus
+ source = git+https://github.com/irreleph4nt/mkinitcpio-bluetooth.git#tag=v1.3
+ md5sums = SKIP
+
+pkgname = mkinitcpio-bluetooth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24fe4d47ad98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Robert Maerz
+# Contributor: Aline Freitas <aline AT alinefreitas DOT com DOT br>
+
+pkgname=mkinitcpio-bluetooth
+pkgver=1.3
+pkgrel=1
+pkgdesc="This is an initcpio hook for bluetooth connectivity during boot / in initramfs."
+url="https://github.com/irreleph4nt/mkinitcpio-bluetooth/"
+arch=('x86_64' 'i686')
+license=('GPLv2')
+depends=('bluez' 'bluez-utils' 'dbus')
+makedepends=('git')
+source=("git+https://github.com/irreleph4nt/mkinitcpio-bluetooth.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ install -Dm644 bluetooth_install "${pkgdir}/usr/lib/initcpio/install/bluetooth"
+ install -Dm644 bluetooth_hook "${pkgdir}/usr/lib/initcpio/hooks/bluetooth"
+ install -Dm644 org.bluez.conf "${pkgdir}/usr/lib/initcpio/bluetooth/org.bluez.conf"
+}
+
+# vim:set ts=2 sw=2 et: