summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimPilotAdamT2022-04-22 23:24:47 +0100
committerSimPilotAdamT2022-04-22 23:24:47 +0100
commitcf725555f5e65565f2024fdf80600a6addcc4fa4 (patch)
tree911a564344efa1ea7567aa6e8bf3319242efd9c2
parent41e69d49c3a5ee1483c7872e320dda1767a98a88 (diff)
downloadaur-cf725555f5e65565f2024fdf80600a6addcc4fa4.tar.gz
1.0.0-5
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7961e48920cd..23361dc8646b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = mkinitcpio-clevis-hook
pkgdesc = A simple hook to unlock LUKS devices on boot with clevis and TPM on Arch Linux and its derivatives, including the non-systemd versions
pkgver = 1.0
- pkgrel = 2
- url = https://github.com/SimPilotAdamT/arch-mkinitcpio-clevis-hook-aur
+ pkgrel = 5
+ url = https://github.com/kishorv06/arch-mkinitcpio-clevis-hook
arch = any
license = GPL3
makedepends = git
@@ -11,7 +11,7 @@ pkgbase = mkinitcpio-clevis-hook
depends = luksmeta
depends = libpwquality
depends = mkinitcpio
- source = git+https://github.com/SimPilotAdamT/arch-mkinitcpio-clevis-hook-aur.git
+ source = git+https://github.com/kishorv06/arch-mkinitcpio-clevis-hook.git/
md5sums = SKIP
pkgname = mkinitcpio-clevis-hook
diff --git a/.gitignore b/.gitignore
index aab1249ce367..3fb397c516b1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@
pkg
src
arch-mkinitcpio-clevis-hook-aur
+arch-mkinitcpio-clevis-hook
*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 6e2b95624900..e17a0e36b126 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=mkinitcpio-clevis-hook
pkgver=1.0
-pkgrel=2
+pkgrel=5
pkgdesc="A simple hook to unlock LUKS devices on boot with clevis and TPM on Arch Linux and its derivatives, including the non-systemd versions"
arch=('any')
-url="https://github.com/SimPilotAdamT/arch-mkinitcpio-clevis-hook-aur"
+url="https://github.com/kishorv06/arch-mkinitcpio-clevis-hook"
license=("GPL3")
depends=("clevis" "tpm2-tools" "luksmeta" "libpwquality" "mkinitcpio")
makedepends=("git")
-source=("git+$url.git")
+source=("git+$url.git/")
md5sums=("SKIP")
build() {
printf ""
@@ -18,6 +18,6 @@ build() {
package() {
mkdir -p "$pkgdir"/etc/initcpio/hooks/
mkdir -p "$pkgdir"/etc/initcpio/install/
- install -Dm644 "$srcdir"/arch-mkinitcpio-clevis-hook-aur/hooks/clevis "$pkgdir"/etc/initcpio/hooks/
- install -Dm644 "$srcdir"/arch-mkinitcpio-clevis-hook-aur/install/clevis "$pkgdir"/etc/initcpio/install/
+ install -Dm644 "$srcdir"/arch-mkinitcpio-clevis-hook/hooks/clevis "$pkgdir"/etc/initcpio/hooks/
+ install -Dm644 "$srcdir"/arch-mkinitcpio-clevis-hook/install/clevis "$pkgdir"/etc/initcpio/install/
}