summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2020-01-15 15:14:46 +0100
committerRichard Neumann2020-01-15 15:14:46 +0100
commitcaef07bfa88d2ba9cb71b3391bf1940afd1a7830 (patch)
tree5263ea7a710f7630a60bad7a376751306a45287a
parent0cbacf391bcfcaa64e284d0194c0a1d531a51be1 (diff)
downloadaur-mkinitcpio-fbsplash.tar.gz
Outsourced project data.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
-rw-r--r--fbsplash.hook18
-rw-r--r--fbsplash.install9
-rwxr-xr-xmkfbsplash74
6 files changed, 14 insertions, 122 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea9bfca14c38..5938bffe976b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu May 18 19:29:30 UTC 2017
pkgbase = mkinitcpio-fbsplash
pkgdesc = Tools to include a framebuffer based boot splash within the initcpio
pkgver = 1.0.4
- pkgrel = 1
- url = https://aur.archlinux.org/packages/mkinitcpio-fbsplash/
+ pkgrel = 2
+ url = https://github.com/coNQP/mkinitcpio-fbsplash
arch = any
license = GPL3
+ makedepends = git
depends = bash
optdepends = fbv: for image generation script.
- conflicts = fbsplash
- source = fbsplash.hook
- source = fbsplash.install
- source = mkfbsplash
- sha256sums = 160a1dcf8b0929ccdabb1327231c6d4bedf6ae96627b84196a0bb52a1f490f93
- sha256sums = 2b16aa38772542d19be1c5aa652641b2acc189c2428a35681b8e55d7486e1668
- sha256sums = e385cd23b89de7ce859265fc5d60a8437779c4fb3ce17e09a832075ba3ee0654
+ source = mkinitcpio-fbsplash::git+https://github.com/coNQP/mkinitcpio-fbsplash.git#tag=1.0.4
+ sha256sums = SKIP
pkgname = mkinitcpio-fbsplash
diff --git a/.gitignore b/.gitignore
index 0cfa4c3ebb1b..60bdcaa44f83 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*.pkg.tar.xz
pkg
src
+mkinitcpio-fbsplash/*
diff --git a/PKGBUILD b/PKGBUILD
index df34391b6350..6148cc033308 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,26 @@
pkgname='mkinitcpio-fbsplash'
pkgver='1.0.4'
-pkgrel=1
-url="https://aur.archlinux.org/packages/${pkgname}/"
+pkgrel=2
+url="https://github.com/coNQP/${pkgname}"
pkgdesc='Tools to include a framebuffer based boot splash within the initcpio'
arch=('any')
license=('GPL3')
depends=('bash')
optdepends=('fbv: for image generation script.')
-source=('fbsplash.hook' 'fbsplash.install' 'mkfbsplash')
-sha256sums=('160a1dcf8b0929ccdabb1327231c6d4bedf6ae96627b84196a0bb52a1f490f93'
- '2b16aa38772542d19be1c5aa652641b2acc189c2428a35681b8e55d7486e1668'
- 'e385cd23b89de7ce859265fc5d60a8437779c4fb3ce17e09a832075ba3ee0654')
-conflicts=('fbsplash')
+makedepends=('git')
+source=("${pkgname}::git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
package() {
# Install initcpio hook and install script
install -d -m 755 ${pkgdir}/usr/lib/initcpio/{hooks,install}
- install -m 644 ${srcdir}/fbsplash.hook ${pkgdir}/usr/lib/initcpio/hooks/fbsplash
- install -m 644 ${srcdir}/fbsplash.install ${pkgdir}/usr/lib/initcpio/install/fbsplash
+ install -m 644 ${srcdir}/${pkgname}/fbsplash.hook ${pkgdir}/usr/lib/initcpio/hooks/fbsplash
+ install -m 644 ${srcdir}/${pkgname}/fbsplash.install ${pkgdir}/usr/lib/initcpio/install/fbsplash
# Install image generation script
install -d -m 755 ${pkgdir}/usr/bin
- install -m 755 ${srcdir}/mkfbsplash ${pkgdir}/usr/bin/
+ install -m 755 ${srcdir}/${pkgname}/mkfbsplash ${pkgdir}/usr/bin/
}
diff --git a/fbsplash.hook b/fbsplash.hook
deleted file mode 100644
index a33d2f05d950..000000000000
--- a/fbsplash.hook
+++ /dev/null
@@ -1,18 +0,0 @@
-#! /usr/bin/bash
-
-# Copies the splash image into the framebuffer device
-run_hook() {
- local FBDEV="/dev/fb0"
- local SPLASH_IMAGE="/etc/splash.fb"
-
- if [ -c "${FBDEV}" ]; then
- if [ -f "${SPLASH_IMAGE}" ]; then
- dd if="${SPLASH_IMAGE}" of="${FBDEV}" 2> /dev/null
- else
- echo "Cannot find ${SPLASH_IMAGE}." >&2
- echo "Did you include it in the \"FILES=...\" of your /etc/mkinitcpio.conf?" >&2
- fi
- else
- echo "Framebuffer device \"${FBDEV}\" is not present." >&2
- fi
-}
diff --git a/fbsplash.install b/fbsplash.install
deleted file mode 100644
index 9ff9504ddfe2..000000000000
--- a/fbsplash.install
+++ /dev/null
@@ -1,9 +0,0 @@
-#! /usr/bin/bash
-
-build() {
- add_runscript
-}
-
-help() {
- echo "This hook shows a simple framebuffer based splash screen."
-}
diff --git a/mkfbsplash b/mkfbsplash
deleted file mode 100755
index a03ecb0d1ec3..000000000000
--- a/mkfbsplash
+++ /dev/null
@@ -1,74 +0,0 @@
-#! /usr/bin/bash
-#
-# This file is part of mkinitcpio-fbsplash.
-#
-# mkinitcpio-fbsplash is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# mkinitcpio-fbsplash is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with mkinitcpio-fbsplash. If not, see <http://www.gnu.org/licenses/>.
-#
-################################################################################
-
-IMAGE=
-FB_DEV="/dev/fb0"
-OUT_FILE="/etc/splash.fb"
-SCRIPT_NAME="$(basename $0)"
-DESC="${SCRIPT_NAME} - Generates a framebuffer boot splash from an image file."
-USAGE="Usage:
- ${SCRIPT_NAME} <image_file> [options]"
-OPTIONS="Options:
- --dev, -d <framebuffer_device> Specifies the framebuffer device to be used.
- Deftaults to ${FB_DEV}.
- --file, -f, -o <output_file> Specifies the output file to be written to.
- Defaults to ${OUT_FILE}."
-
-while (($#)); do
- case $1 in
- "--dev"|"-d") FB_DEV="$2"
- shift
- ;;
- "--file"|"-f"|"-o") OUT_FILE="$2"
- shift
- ;;
- "--help"|"-h") echo -e "${DESC}\n"
- echo -e "${USAGE}\n"
- echo "${OPTIONS}"
- exit 0
- ;;
- *) if [ -z "${IMAGE}" ]; then
- IMAGE="$1"
- else
- echo "Unknown parameter: $1" >&2
- echo "${USAGE}" >&2
- exit 1
- fi
- esac
- shift
-done
-
-if [ -z "${IMAGE}" ]; then
- echo "${USAGE}" >&2
- exit 2
-elif [ ! -f "${IMAGE}" ]; then
- echo "Selected image does not exist." >&2
- exit 3
-fi
-
-if [ ${EUID} -ne 0 ]; then
- echo "You need to be root to run this script" >&2
- exit 4
-fi
-
-TEMP=$(mktemp)
-/usr/bin/fbv -c -i -d 1 "${IMAGE}"
-/usr/bin/cp "${FB_DEV}" "${TEMP}"
-/usr/bin/mv -i "${TEMP}" "${OUT_FILE}"
-/usr/bin/rm -f "${TEMP}"