summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2022-10-25 10:12:23 +0200
committerChristian Hesse2022-10-25 10:12:23 +0200
commit440281f1fc69a00a72638ca64d00cc309e4c5152 (patch)
tree97b6ba48052d426157f369402976ad56f03b7161
parentb6553d725b6ee0e08febea1af998c1fdbb800a53 (diff)
downloadaur-440281f1fc69a00a72638ca64d00cc309e4c5152.tar.gz
commit mkinitcpio-git 32.r0.g0be0de5-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffba53c8e018..6f43d043a41b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkinitcpio-git
pkgdesc = Modular initramfs image creation utility - git checkout
- pkgver = 30.r18.gf40bb42
+ pkgver = 32.r0.g0be0de5
pkgrel = 1
url = https://github.com/archlinux/mkinitcpio
arch = any
@@ -14,20 +14,27 @@ pkgbase = mkinitcpio-git
depends = libarchive
depends = coreutils
depends = bash
+ depends = binutils
+ depends = diffutils
depends = findutils
depends = grep
depends = filesystem
- depends = gzip
- depends = systemd-tools
+ depends = zstd
+ depends = systemd
+ optdepends = gzip: Use gzip compression for the initramfs image
optdepends = xz: Use lzma or xz compression for the initramfs image
optdepends = bzip2: Use bzip2 compression for the initramfs image
optdepends = lzop: Use lzo compression for the initramfs image
+ optdepends = lz4: Use lz4 compression for the initramfs image
optdepends = mkinitcpio-nfs-utils: Support for root filesystem on NFS
provides = initramfs
- provides = mkinitcpio=30.r18.gf40bb42
+ provides = mkinitcpio=32.r0.g0be0de5
conflicts = mkinitcpio
backup = etc/mkinitcpio.conf
- source = git+https://github.com/archlinux/mkinitcpio.git
+ source = git+https://github.com/archlinux/mkinitcpio.git?signed
+ validpgpkeys = ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB
+ validpgpkeys = C100346676634E80C940FB9E9C02FF419FECBE16
+ validpgpkeys = BB8E6F1B81CF0BB301D74D1CBF425A01E68B38EF
sha256sums = SKIP
pkgname = mkinitcpio-git
diff --git a/PKGBUILD b/PKGBUILD
index 19c1cbee1a27..316f8c5a5452 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,38 +3,34 @@
# Maintainer: Thomas Bächler <thomas@archlinux.org> ([core] package)
pkgname=mkinitcpio-git
-pkgver=30.r18.gf40bb42
+pkgver=32.r0.g0be0de5
pkgrel=1
pkgdesc='Modular initramfs image creation utility - git checkout'
arch=('any')
url='https://github.com/archlinux/mkinitcpio'
license=('GPL')
depends=('awk' 'mkinitcpio-busybox' 'kmod' 'util-linux' 'libarchive' 'coreutils'
- 'bash' 'findutils' 'grep' 'filesystem' 'gzip' 'systemd-tools')
-optdepends=('xz: Use lzma or xz compression for the initramfs image'
+ 'bash' 'binutils' 'diffutils' 'findutils' 'grep' 'filesystem' 'zstd' 'systemd')
+optdepends=('gzip: Use gzip compression for the initramfs image'
+ 'xz: Use lzma or xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
+ 'lz4: Use lz4 compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
makedepends=('git' 'asciidoc')
provides=('initramfs' "mkinitcpio=${pkgver}")
conflicts=('mkinitcpio')
backup=('etc/mkinitcpio.conf')
-source=('git+https://github.com/archlinux/mkinitcpio.git')
+source=('git+https://github.com/archlinux/mkinitcpio.git?signed')
sha256sums=('SKIP')
+validpgpkeys=('ECCAC84C1BA08A6CC8E63FBBF22FB1D78A77AEAB' # Giancarlo Razzolini
+ 'C100346676634E80C940FB9E9C02FF419FECBE16' # Morten Linderud
+ 'BB8E6F1B81CF0BB301D74D1CBF425A01E68B38EF') # nl6720
pkgver() {
cd mkinitcpio/
- if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- printf '%s.r%s.g%s' \
- "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
- "$(git rev-list --count ${GITTAG}..)" \
- "$(git rev-parse --short HEAD)"
- else
- printf '0.r%s.g%s' \
- "$(git rev-list --count master)" \
- "$(git rev-parse --short HEAD)"
- fi
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
@@ -42,4 +38,3 @@ package() {
make DESTDIR="${pkgdir}" install
}
-