summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas2019-07-24 19:54:28 +0200
committerAndreas2019-07-24 19:54:28 +0200
commit793237216266b432cc3b233e3f85786de187d4a6 (patch)
tree2aea73874c17e3ceb50bde29e67c109af963c069
downloadaur-793237216266b432cc3b233e3f85786de187d4a6.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD20
-rw-r--r--haveged.hook15
-rw-r--r--haveged.install15
5 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d01feba13402
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mkinitcpio-haveged
+ pkgdesc = mkinitcpio hook to run haveged for entropy generation
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://aur.archlinux.org/packages/mkinitcpio-haveged/
+ arch = any
+ license = GPL
+ depends = mkinitcpio
+ depends = haveged
+ source = haveged.hook
+ source = haveged.install
+ sha256sums = cd412ba46b4b6f0862567940a1632c8f5d837d4245a6d9553839c29c1805d0e8
+ sha256sums = fe18ff703bd3d9a9f5a9ee05922f93de253a7a961c79e97ffea30cf37617df9a
+
+pkgname = mkinitcpio-haveged
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..511c79207879
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.pkg.tar.*
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00d5bd2e7955
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: tequa
+pkgname=mkinitcpio-haveged
+pkgver=0.1
+pkgrel=1
+pkgdesc="mkinitcpio hook to run haveged for entropy generation"
+arch=(any)
+license=('GPL')
+url="https://aur.archlinux.org/packages/mkinitcpio-haveged/"
+depends=(mkinitcpio haveged)
+source=('haveged.hook'
+ 'haveged.install')
+sha256sums=('cd412ba46b4b6f0862567940a1632c8f5d837d4245a6d9553839c29c1805d0e8'
+ 'fe18ff703bd3d9a9f5a9ee05922f93de253a7a961c79e97ffea30cf37617df9a')
+
+package() {
+ install -Dm 644 haveged.hook \
+ "${pkgdir}/usr/lib/initcpio/hooks/haveged"
+ install -Dm 644 haveged.install \
+ "${pkgdir}/usr/lib/initcpio/install/haveged"
+}
diff --git a/haveged.hook b/haveged.hook
new file mode 100644
index 000000000000..95bf41f6fc95
--- /dev/null
+++ b/haveged.hook
@@ -0,0 +1,15 @@
+#!/usr/bin/ash
+
+run_hook ()
+{
+ echo "Starting haveged"
+
+ # start haveged running in the background
+ haveged
+}
+
+run_cleanuphook ()
+{
+ # kill haveged running in the background
+ killall haveged
+}
diff --git a/haveged.install b/haveged.install
new file mode 100644
index 000000000000..c55aa6c6aaf5
--- /dev/null
+++ b/haveged.install
@@ -0,0 +1,15 @@
+#!/bin/bash
+
+build ()
+{
+ add_binary "killall"
+ add_binary "haveged"
+ add_runscript
+}
+
+help ()
+{
+cat<<HELPEOF
+ Enables haveged on boot, for increased rng entropy.
+HELPEOF
+}