summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractra.development (OSS)2019-06-18 21:30:41 +0200
committeractra.development (OSS)2019-06-18 21:30:41 +0200
commitb1a3e1632ef099ee60cca6adf297091536dc0df1 (patch)
treeb1cb887b62eedaa79262c06336d531cc3a4a5176
downloadaur-b1a3e1632ef099ee60cca6adf297091536dc0df1.tar.gz
Added package info
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD44
-rw-r--r--mkinitcpio-knockencryptssh.install46
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f3c88a3aee9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mkinitcpio-knockencryptssh
+ pkgdesc = Remotely unlock LUKS over SSH with keyfile support by port-knocking first
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/actra-development-oss/mkinitcpio-knockencryptssh
+ install = mkinitcpio-knockencryptssh.install
+ arch = any
+ license = MIT
+ depends = mkinitcpio
+ depends = knockd
+ depends = inotify-tools
+ depends = cryptsetup
+ depends = device-mapper
+ depends = gawk
+ depends = bash
+ backup = etc/knockencryptssh/knockd.conf
+ source = https://raw.githubusercontent.com/actra-development-oss/mkinitcpio-knockencryptssh/master/mkinitcpio-knockencryptssh.tar.gz
+ md5sums = fdc6570659e482210dae8978b11f0357
+
+pkgname = mkinitcpio-knockencryptssh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d8fe4fa70f61
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/.project
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26bf88d09f30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: actra.development <opensource@actra.de>
+pkgname=mkinitcpio-knockencryptssh
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc="Remotely unlock LUKS over SSH with keyfile support by port-knocking first"
+arch=('any')
+url="https://github.com/actra-development-oss/mkinitcpio-knockencryptssh"
+license=('MIT')
+groups=()
+depends=('mkinitcpio'
+ 'knockd'
+ 'inotify-tools'
+ 'cryptsetup'
+ 'device-mapper'
+ 'gawk'
+ 'bash')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=('etc/knockencryptssh/knockd.conf')
+options=()
+install='mkinitcpio-knockencryptssh.install'
+changelog=
+source=('https://raw.githubusercontent.com/actra-development-oss/mkinitcpio-knockencryptssh/master/mkinitcpio-knockencryptssh.tar.gz')
+noextract=()
+md5sums=('fdc6570659e482210dae8978b11f0357')
+validpgpkeys=()
+
+package() {
+ install -Dm 644 src/usr/lib/initcpio/hooks/knockencryptssh "${pkgdir}/usr/lib/initcpio/hooks/knockencryptssh"
+ install -Dm 644 src/usr/lib/initcpio/install/knockencryptssh "${pkgdir}/usr/lib/initcpio/install/knockencryptssh"
+ mkdir -p -m 755 "${pkgdir}/etc/knockencryptssh"
+ install -Dm 644 src/etc/knockencryptssh/knockd.conf "${pkgdir}/etc/knockencryptssh/knockd.conf"
+ install -Dm 755 src/etc/knockencryptssh/knocked.sh "${pkgdir}/etc/knockencryptssh/knocked.sh"
+ mkdir -p -m 755 "${pkgdir}/usr/share/mkinitcpio-knockencryptssh/utils/shells"
+ install -Dm 755 src/utils/shells/cryptsetup_shell "${pkgdir}/usr/share/mkinitcpio-knockencryptssh/utils/shells/cryptsetup_shell"
+ mkdir -p -m 644 "${pkgdir}/usr/share/mkinitcpio-knockencryptssh/examples"
+ install -Dm 644 src/examples/linux.sh "${pkgdir}/usr/share/mkinitcpio-knockencryptssh/examples/linux.sh"
+ install -Dm 644 src/examples/windows.bat "${pkgdir}/usr/share/mkinitcpio-knockencryptssh/examples/windows.bat"
+} \ No newline at end of file
diff --git a/mkinitcpio-knockencryptssh.install b/mkinitcpio-knockencryptssh.install
new file mode 100644
index 000000000000..1c6af8c3ba75
--- /dev/null
+++ b/mkinitcpio-knockencryptssh.install
@@ -0,0 +1,46 @@
+post_install() {
+ echo ""
+ echo ""
+ echo "################################################"
+ echo "##### #####"
+ echo "##### Hints on configuring knockencryptssh #####"
+ echo "##### #####"
+ echo "################################################"
+ echo ""
+ echo "Modify the configuration at /etc/knockencryptssh/knockencryptssh.conf"
+ echo ""
+ echo " [knockencryptssh]"
+ echo " keyfile: Filename of the keyfile that'll be transferred"
+ echo " tempdir: Temporary directory where knockd will put it's knock alerts and"
+ echo " knockencryptssh will pick them up"
+ echo ""
+ echo ""
+ echo "Modify the configuration at /etc/knockencryptssh/knockd.conf"
+ echo ""
+ echo " [options]"
+ echo " interface: specify the interface knockd should listen on"
+ echo ""
+ echo " [knockKeyfile]"
+ echo " sequence: specify the port sequence that marks a knock for keyfile"
+ echo " transmission, this should be a port that your SSH server (e.g."
+ echo " dropbear or tinyssh) does not listen on"
+ echo ""
+ echo " [knockPassphrase]"
+ echo " sequence: specify the port sequence that marks a knock for passphrase"
+ echo " entry, this should usually be the standard port your SSH server"
+ echo " (e.g. dropbear or tinyssh) listens on"
+ echo ""
+ echo ""
+ echo "Don't forget to add the knockencryptssh hook after netconf and "
+ echo "<your SSH server hook> (e.g. dropbear or tinyssh) but before lvm2 in your"
+ echo "/etc/mkinitcpio.conf so it'll look like:"
+ echo " HOOKS=(base ... netconf dropbear knockencryptssh lvm2 filesystems ...)"
+ echo "Run 'mkinitcpio -p linux' afterwards to generate the new initramfs"
+ echo ""
+ echo "Hint: This hook replaces the commonly known encrypt and encryptssh hooks so"
+ echo " you might want to remove those hooks if present"
+ echo ""
+ echo ""
+
+ sleep 10
+} \ No newline at end of file