summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAetf2020-04-03 23:21:57 -0400
committerAetf2020-04-03 23:21:57 -0400
commit1cc3519831fd78f83d74a8263c7ddc40cfbd30e0 (patch)
treeccfdb13bf4b026f798f7dfdeac5a62d611654637
downloadaur-1cc3519831fd78f83d74a8263c7ddc40cfbd30e0.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore13
-rw-r--r--90-mkinitcpio-modconf-update.hook13
-rw-r--r--PKGBUILD29
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d51d4fae9c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mkinitcpio-modconf-hook-git
+ pkgdesc = Pacman hook to run mkinitcpio after updates to packaged modprobe.d config files
+ pkgver = 20200401.5ebf708
+ pkgrel = 1
+ url = https://github.com/Aetf/mkinitcpio-modconf-hook
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = mkinitcpio
+ source = git+https://github.com/Aetf/mkinitcpio-modconf-hook
+ sha256sums = SKIP
+
+pkgname = mkinitcpio-modconf-hook-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8db5aa808c80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+# Ignore downloaded source files
+*.tar.gz
+*.tar.xz
+*.tgz
+
+# Ignore packages
+*.pkg.tar.xz
+
+# Ignore log files
+*.log
+
+# Ignore all subdirs
+*/*
diff --git a/90-mkinitcpio-modconf-update.hook b/90-mkinitcpio-modconf-update.hook
new file mode 100644
index 000000000000..cb2c20a0ff86
--- /dev/null
+++ b/90-mkinitcpio-modconf-update.hook
@@ -0,0 +1,13 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Target = usr/lib/modprobe.d/*
+Target = etc/modprobe.d/*
+
+[Action]
+Description = Updating linux initcpios...
+When = PostTransaction
+Exec = /usr/share/libalpm/scripts/mkinitcpio-install
+NeedsTargets
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..964ca0dab803
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aetf <aetf@unlimitedcodeworks.xyz>
+
+pkgname=mkinitcpio-modconf-hook-git
+_pkgname=mkinitcpio-modconf-hook
+
+pkgver=20200403.9c3fafe
+pkgrel=1
+
+url="https://github.com/Aetf/mkinitcpio-modconf-hook"
+arch=('any')
+license=('Apache')
+pkgdesc="Pacman hook to run mkinitcpio after updates to packaged modprobe.d config files"
+
+depends=('mkinitcpio')
+makedepends=('git')
+
+source=("git+https://github.com/Aetf/$_pkgname")
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/"$_pkgname"
+ git log -1 --format=%cd.%h --date=short|tr -d -
+}
+
+package() {
+ cd "$srcdir"/"$_pkgname"
+ install -Dm644 90-modconf-update.hook "${pkgdir}"/usr/share/libalpm/hooks/90-modconf-update.hook
+}