summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2015-08-11 17:15:25 -0300
committerGiancarlo Razzolini2015-08-11 17:15:25 -0300
commit137bce5edeeabdb9331c14b72007ab22487151f9 (patch)
treecff659cb2a168abe25bd819199ea075c69d766e2
parent354addb488a4cf8904fc2ee10d9148dc3ae5c372 (diff)
downloadaur-137bce5edeeabdb9331c14b72007ab22487151f9.tar.gz
* Version 0.0.2:
- Initial support for systemd enabled initrd: + Check for any files ending in .initramfs in the /etc/systemd/network directory, and copies them to the initrd, and also copy and install systemd-networkd. + There are some caveats, specially that it won't remove any ip addresses added to the interface: https://github.com/systemd/systemd/issues/780 - Corrected the help text.
-rw-r--r--.gitignore1
-rw-r--r--Changelog8
-rw-r--r--PKGBUILD4
3 files changed, 11 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 86f4c3b5ebc4..5b33e2aa5ba0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
v*.tar.gz
mkinitcpio-netconf-*-any.pkg.tar.xz
mkinitcpio-netconf-*.src.tar.gz
+develop.*
diff --git a/Changelog b/Changelog
index bf7f447caa91..5ac3d7f95fa9 100644
--- a/Changelog
+++ b/Changelog
@@ -1,3 +1,11 @@
+2015-08-11 Giancarlo Razzolini <grazzolini@gmail.com>
+
+ * 0.0.2 :
+ - Initial support for systemd enabled initrd:
+ + Check for any files ending in .initramfs in the /etc/systemd/network directory, and copies them to the initrd, and also copy and install systemd-networkd.
+ + There are some caveats, specially that it won't remove any ip addresses added to the interface: https://github.com/systemd/systemd/issues/780
+ - Corrected the help text.
+
2015-07-15 Giancarlo Razzolini <grazzolini@gmail.com>
* 0.0.1 :
diff --git a/PKGBUILD b/PKGBUILD
index aec79b85d3bc..c8d5a803dee8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Giancarlo Razzolini <grazzolini@gmail.com>
pkgname=mkinitcpio-netconf
-pkgver=0.0.1
+pkgver=0.0.2
pkgrel=1
pkgdesc="Archlinux mkinitcpio hook for configuring early userspace networking"
arch=('any')
@@ -10,7 +10,7 @@ depends=('mkinitcpio-nfs-utils' 'iproute2')
install=$pkgname.install
source=($url/archive/v$pkgver.tar.gz)
changelog='Changelog'
-sha512sums=('86a79da8994b79df34407744400a5fc125e984e7550068e176d98e1c348e3c0bed78f21e901a215c10de6eb65beac53cfdb17ee73014a7ab38ac09ce937c634c')
+sha512sums=('d63b763dd5093ac6f18042ce3c9971c0293bc4dcf364bfb4fb33cdfafc8b4eaed705cc90148e972bf8d8e5b34e636fe854b4c8613fa5e2f7a2859fa247434951')
package() {
install -Dm644 "$srcdir/$pkgname-$pkgver/netconf_hook" "$pkgdir/usr/lib/initcpio/hooks/netconf"