summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2016-08-26 13:32:51 -0300
committerGiancarlo Razzolini2016-08-26 13:32:51 -0300
commit7e5494872036d6a94e652e56b6b457623341ca86 (patch)
treeae4505e29f99ce6fa6021053b9e0c02fc1db71c8
parent78e12904206bb5e145af5d4efae385e0aa26f36a (diff)
downloadaur-7e5494872036d6a94e652e56b6b457623341ca86.tar.gz
* Commit of version 0.0.4.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--mkinitcpio-netconf.install12
3 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26796f65bc92..a54fa95c5aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Aug 9 12:12:30 UTC 2016
+# Fri Aug 26 16:32:03 UTC 2016
pkgbase = mkinitcpio-netconf
pkgdesc = Archlinux mkinitcpio hook for configuring early userspace networking
- pkgver = 0.0.3
- pkgrel = 2
+ pkgver = 0.0.4
+ pkgrel = 1
url = https://github.com/grazzolini/mkinitcpio-netconf
install = mkinitcpio-netconf.install
changelog = Changelog
@@ -11,8 +11,8 @@ pkgbase = mkinitcpio-netconf
license = BSD
depends = mkinitcpio-nfs-utils
depends = iproute2
- source = mkinitcpio-netconf-0.0.3.tar.gz::https://github.com/grazzolini/mkinitcpio-netconf/archive/v0.0.3.tar.gz
- sha512sums = d526ced87ef13d6a4c22c22810b0024ca51095a82a28c210fc202e73499ca8aa7a16d3f45c3c549996fbd4ed220afa15df178f93aaacfc4a547d9042f69fa760
+ source = mkinitcpio-netconf-0.0.4.tar.gz::https://github.com/grazzolini/mkinitcpio-netconf/archive/v0.0.4.tar.gz
+ sha512sums = 06ac202410964740785d2977f7918981276e10568260433436c51a1d540152cc28462e46dae6bfa31acd1fafa9ebe1e4f57ca90d7754a09ccaba142c8d48b228
pkgname = mkinitcpio-netconf
diff --git a/PKGBUILD b/PKGBUILD
index a3440f7f0ae8..c09e278a68d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Giancarlo Razzolini <grazzolini@gmail.com>
pkgname=mkinitcpio-netconf
-pkgver=0.0.3
-pkgrel=2
+pkgver=0.0.4
+pkgrel=1
pkgdesc="Archlinux mkinitcpio hook for configuring early userspace networking"
arch=('any')
url="https://github.com/grazzolini/mkinitcpio-netconf"
@@ -10,10 +10,11 @@ depends=('mkinitcpio-nfs-utils' 'iproute2')
install=$pkgname.install
source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v$pkgver.tar.gz")
changelog='Changelog'
-sha512sums=('d526ced87ef13d6a4c22c22810b0024ca51095a82a28c210fc202e73499ca8aa7a16d3f45c3c549996fbd4ed220afa15df178f93aaacfc4a547d9042f69fa760')
+sha512sums=('06ac202410964740785d2977f7918981276e10568260433436c51a1d540152cc28462e46dae6bfa31acd1fafa9ebe1e4f57ca90d7754a09ccaba142c8d48b228')
package() {
- install -Dm644 "$srcdir/$pkgname-$pkgver/netconf_hook" "$pkgdir/usr/lib/initcpio/hooks/netconf"
- install -Dm644 "$srcdir/$pkgname-$pkgver/netconf_install" "$pkgdir/usr/lib/initcpio/install/netconf"
+ install -Dm644 $srcdir/$pkgname-$pkgver/netconf_hook $pkgdir/usr/lib/initcpio/hooks/netconf
+ install -Dm644 $srcdir/$pkgname-$pkgver/netconf_install $pkgdir/usr/lib/initcpio/install/netconf
+ install -Dm644 $srcdir/$pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/mkinitcpio-netconf.install b/mkinitcpio-netconf.install
index c9e04f887c80..cb105426f564 100644
--- a/mkinitcpio-netconf.install
+++ b/mkinitcpio-netconf.install
@@ -7,8 +7,10 @@ post_install() {
It is meant to be used alongside other hooks that need early userspace networking
such as, mkinitcpio-dropbear. There is also an optional netconf_timeout kernel
command line argument that can be used when obtaining the ip address using dhcp, so
- that ipconfig will not hang forever waiting for an IP addres. To use this hook
- add the netconf hook before any other hook that need networking in
+ that ipconfig will not hang forever waiting for an IP addres. You can nest multiple ip=
+ parameters inside a single ip= parameter, separated by : to configure multiple interfaces.
+ There is no limit on the number of interfaces configured, but the kernel cmdline size.
+ To use this hook add the netconf hook before any other hook that need networking in
"/etc/mkinitcpio.conf" and rebuild the initramfs.
INSTALLEOF
}
@@ -23,9 +25,13 @@ REMOVEEOF
post_upgrade() {
cat<<UPGRADEEOF
- There is now an optiona kernel command line parameter named netconf_timeout that
+ There is now an optional kernel command line parameter named netconf_timeout that
is used to pass the timeout option to ipconfig. This is means that when using
ip=dhcp as a kernel command line parameter, ipconfig will not hang forever if the
dhcp server is unavailable.
+
+ You can also now nest multiple ip= parameters inside a single ip= parameter,
+ separated by : to configure multiple interfaces. There is no limit on the number
+ of interfaces configured, but the kernel cmdline size.
UPGRADEEOF
}