summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2017-08-29 16:06:20 +0200
committerChristian Hesse2017-08-29 16:06:20 +0200
commit78b233d8dfa1781420a1c6688298624393be8026 (patch)
tree95314f61c1bebd84455e9a528e22a108e23f8ea6
parent652445b05ff153050a5e30c57f11bfe2316b3fa6 (diff)
downloadaur-78b233d8dfa1781420a1c6688298624393be8026.tar.gz
commit mkinitcpio-git 23.r6.g32dbf89-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aabd876be4ce..af7e78c92966 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 24 09:23:08 UTC 2017
+# Tue Aug 29 14:06:20 UTC 2017
pkgbase = mkinitcpio-git
pkgdesc = Modular initramfs image creation utility - git checkout
- pkgver = 23.r2.g91b2125
+ pkgver = 23.r6.g32dbf89
pkgrel = 1
url = http://www.archlinux.org/
arch = any
@@ -25,7 +25,7 @@ pkgbase = mkinitcpio-git
optdepends = bzip2: Use bzip2 compression for the initramfs image
optdepends = lzop: Use lzo compression for the initramfs image
optdepends = mkinitcpio-nfs-utils: Support for root filesystem on NFS
- provides = mkinitcpio
+ provides = mkinitcpio=23.r6.g32dbf89
conflicts = mkinitcpio
backup = etc/mkinitcpio.conf
source = git://projects.archlinux.org/mkinitcpio.git
diff --git a/PKGBUILD b/PKGBUILD
index e3fc79273df1..7f2ad9f7d0bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Thomas Bächler <thomas@archlinux.org> ([core] package)
pkgname=mkinitcpio-git
-pkgver=23.r2.g91b2125
+pkgver=23.r6.g32dbf89
pkgrel=1
pkgdesc='Modular initramfs image creation utility - git checkout'
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('xz: Use lzma or xz compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
makedepends=('git' 'asciidoc')
-provides=('mkinitcpio')
+provides=("mkinitcpio=${pkgver}")
conflicts=('mkinitcpio')
backup=('etc/mkinitcpio.conf')
source=('git://projects.archlinux.org/mkinitcpio.git')
@@ -26,9 +26,14 @@ pkgver() {
cd mkinitcpio/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
fi
}