summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJenya Sovetkin2017-10-14 16:23:30 +0200
committerJenya Sovetkin2017-10-14 16:23:30 +0200
commit278d5e52c11bd7d4d52b655c3bd889630fb1ae1c (patch)
tree41fbf1343445af5732421b6b8cf22c8460f8eefc
parenta889bd8e610a4edc79cf07934f70b9cec7201685 (diff)
downloadaur-278d5e52c11bd7d4d52b655c3bd889630fb1ae1c.tar.gz
fix from dreieck
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--openswap.hook2
3 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b35c6ba215b..b3e4c56f1321 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Tue Dec 6 09:31:41 UTC 2016
pkgbase = mkinitcpio-openswap
pkgdesc = mkinitcpio hook to open swap at boot time
pkgver = 0.1.0
@@ -13,7 +11,7 @@ pkgbase = mkinitcpio-openswap
source = openswap.hook
source = openswap.install
source = openswap.conf
- sha256sums = ec55cff2d8f71eae70535e706445edb41f416350245b7aa7b322581fd3b38bae
+ sha256sums = b3ba16919450c229093adfbb758b72e2b31a8cbbc25e42e47693b9d0f4cc8a5b
sha256sums = 94dd98a953bab2244215a2b20767cdc9500fc438bed9ec27cae72a73766c6b86
sha256sums = 3308f2679bb7c962d98adf2684d25390025d025e3d30bc1e773e3522311ad325
diff --git a/PKGBUILD b/PKGBUILD
index 36a1c66a74e0..d3e7b26aa61a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributors: https://aur.archlinux.org/account/f4bio
pkgname=mkinitcpio-openswap
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="mkinitcpio hook to open swap at boot time"
arch=(any)
license=('unknown')
@@ -13,7 +13,7 @@ install="usage.install"
source=('openswap.hook'
'openswap.install'
'openswap.conf')
-sha256sums=('ec55cff2d8f71eae70535e706445edb41f416350245b7aa7b322581fd3b38bae'
+sha256sums=('b3ba16919450c229093adfbb758b72e2b31a8cbbc25e42e47693b9d0f4cc8a5b'
'94dd98a953bab2244215a2b20767cdc9500fc438bed9ec27cae72a73766c6b86'
'3308f2679bb7c962d98adf2684d25390025d025e3d30bc1e773e3522311ad325')
diff --git a/openswap.hook b/openswap.hook
index ead4c4f869bb..9aad79a29c2d 100644
--- a/openswap.hook
+++ b/openswap.hook
@@ -6,7 +6,7 @@ run_hook ()
if [ -z "$keyfile_device" ] || [ -z "$keyfile_filename" ]
then
## case when no keyfile provided in configurations
- cryptsetup open "$swap_device" "$crypt_swap_name"
+ cryptsetup open $cryptsetup_options "$swap_device" "$crypt_swap_name"
else
## case when keyfile is provided in configurations
mkdir openswap_keymount