summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2015-06-08 12:35:56 -0300
committerGiancarlo Razzolini2015-06-08 12:35:56 -0300
commitf5d12656273cf777b09b13cf7edb7d039d019b84 (patch)
tree4f4fcbc7cb236072047233c86088e33624ccfe38
downloadaur-f5d12656273cf777b09b13cf7edb7d039d019b84.tar.gz
* Initial commit to migrate mkinitcpio-ppp to the new AUR system.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--ChangeLog23
-rw-r--r--PKGBUILD20
-rw-r--r--mkinitcpio-ppp.install35
5 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..716cf84195be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mkinitcpio-ppp
+ pkgdesc = PPP hook for dialing to a ppp connection inside the initrd. In combination with dropbear_initrd_encrypt, it allows remote unlocking over the internet
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/grazzolini/mkinitcpio-ppp
+ install = mkinitcpio-ppp.install
+ changelog = ChangeLog
+ arch = any
+ license = BSD
+ depends = ppp
+ source = ChangeLog
+ source = mkinitcpio-ppp.install
+ source = https://github.com/grazzolini/mkinitcpio-ppp/archive/v0.0.4.tar.gz
+ sha256sums = 89fdfe80ec692aa671f55abd9d141643bd3039fbc153a10fbd296dbd97790a7a
+ sha256sums = 8b36f75be0f04a9a9c111dc710f43ed06d7e48921e2094421f923a36e0e2a9d9
+ sha256sums = e5fdada28323950bcecf5322734d5a3dfde59edef059a890fedd15d9f5bdd666
+
+pkgname = mkinitcpio-ppp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6f595c16b82a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+v*.tar.gz
+mkinitcpio-ppp-*-any.pkg.tar.xz
+mkinitcpio-ppp-*.src.tar.gz
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..c7745b344ef9
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,23 @@
+2015-06-08 Giancarlo Razzolini <grazzolini@gmail.com>
+
+ * 0.0.4 :
+ - Decouple of the PKGBUILD and other AUR relevant files from the source code for upload in the new AUR system.
+
+2015-01-14 Giancarlo Razzolini <grazzolini@gmail.com>
+
+ * 0.0.3 :
+ - Now it can be used with modems too. Just need to add your modem module to the initramfs.
+ - The ppp_device parameter was changed to be optional, since it can accept not just PPPoE connections.
+
+2015-01-13 Giancarlo Razzolini <grazzolini@gmail.com>
+
+ * 0.0.2 :
+ - The kernel parameters names changed. A new one was added, for setting up the device pre-connection.
+ - There were missing modules that would prevent pppd from running. They were added to the installation.
+ - Changes in the help and install texts.
+
+2015-01-12 Giancarlo Razzolini <grazzolini@gmail.com>
+
+ * 0.0.1 :
+ - Initial release
+ - Support for running a pppd daemon that dials out to a ppp(oe) provider, based on a kernel command line parameter
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fd22b0008eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Giancarlo Razzolini <grazzolini@gmail.com>
+pkgname=mkinitcpio-ppp
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="PPP hook for dialing to a ppp connection inside the initrd. In combination with dropbear_initrd_encrypt, it allows remote unlocking over the internet"
+arch=('any')
+url="https://github.com/grazzolini/mkinitcpio-ppp"
+license=('BSD')
+depends=('ppp')
+install=$pkgname.install
+source=('ChangeLog' "$pkgname.install" $url/archive/v$pkgver.tar.gz)
+changelog='ChangeLog'
+sha256sums=('89fdfe80ec692aa671f55abd9d141643bd3039fbc153a10fbd296dbd97790a7a'
+ '8b36f75be0f04a9a9c111dc710f43ed06d7e48921e2094421f923a36e0e2a9d9'
+ 'e5fdada28323950bcecf5322734d5a3dfde59edef059a890fedd15d9f5bdd666')
+
+package() {
+ install -Dm644 "$srcdir/$pkgname-$pkgver/ppp_hook" "$pkgdir/usr/lib/initcpio/hooks/ppp"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/ppp_install" "$pkgdir/usr/lib/initcpio/install/ppp"
+}
diff --git a/mkinitcpio-ppp.install b/mkinitcpio-ppp.install
new file mode 100644
index 000000000000..5cdcf3fd08da
--- /dev/null
+++ b/mkinitcpio-ppp.install
@@ -0,0 +1,35 @@
+#!/bin/bash
+
+post_install() {
+ cat<<INSTALLEOF
+ First, create a provider file in the /etc/ppp/peers directory and
+ configure your user/secret into /etc/ppp/pap-secrets or /etc/ppp/chap-secrets,
+ depending on your provider configuration. It's advised to test if the connection
+ works before adding the hooks and rebuilding your initramfs.
+
+ Afterwards add to your bootloader configuration two kernel parameters called
+ ppp_provider and ppp_device in which the ppp_provider value is the filename of
+ the provider you created, without the full path. As an example, if your
+ configuration file is /etc/ppp/peers/provider, use ppp_provider=provider.
+ The ppp_device is the physical device used for the ppp connection (in case of
+ PPPoE), such as eth0 or eth1. This parameter is optional, in case your ppp
+ connection is done using a modem. If this is the case, you will need to add your
+ modem's kernel module to the "MODULES" section in /etc/mkinitcpio.conf. This
+ hook is suited for remote unlocking of an encrypted root partition, using the
+ dropbear_initrd_encrypt hooks. Add the "ppp" hook to the "HOOKS" section in
+ "/etc/mkinitcpio.conf" and rebuild the initramfs with ("mkinitcpio -p linux").
+INSTALLEOF
+}
+
+post_remove() {
+ cat<<REMOVEEOF
+ Remove the "ppp" from the "HOOKS" section in "/etc/mkinitcpio.conf", then
+ rebuild the initramfs with ("mkinitcpio -p linux"). Optionally, also remove
+ any provider you might have set in /etc/ppp/peers and any secrets. Or any
+ modem module you possibly used in the "MODULES" section.
+REMOVEEOF
+}
+
+post_upgrade() {
+ post_install
+}