summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2017-06-26 23:17:26 +0200
committerLucas Werkmeister2017-06-26 23:33:17 +0200
commit3222effea7b27fba7bbb1dfc1307c9fc6d23a33a (patch)
treefe120f437cb3bbc05b889b71fdca69ddb4b0319b
parent05b6455d68a15a7f459200a210c9d54b82ac9e3c (diff)
downloadaur-3222effea7b27fba7bbb1dfc1307c9fc6d23a33a.tar.gz
Update for mkosi v2
The optdepends changes are copied over from the mkosi-git package. This also adds a workaround for the forgotten version number bump in the mkosi and setup.py files (see systemd/mkosi#68). I have verified that GitHub’s tarball contains the same tree as the v2 tag in my clone: $ rm -f v2.tar.gz $ wget -q https://github.com/systemd/mkosi/archive/v2.tar.gz $ gunzip < v2.tar.gz | sha256sum f03d43e5f07ee31d32324401f23140c68ad49d8a1a5fd40104347a5a6663fa08 - $ git archive v2 --prefix=mkosi-2/ | sha256sum f03d43e5f07ee31d32324401f23140c68ad49d8a1a5fd40104347a5a6663fa08 - $ sha256sum v2.tar.gz # this is the sha256sum in the PKGBUILD file 1b1df95a95cd02ed4d2473d7be147da0829e24b5f84cea91995d76dab2f90de6 v2.tar.gz I have also verified that the v2 tag in my clone was signed (validly) by the same key [1] that also signed the v232 tag in my clone of the systemd repository. Since I do not have any web-of-trust connection to Lennart Poettering, that will have to do. [1]: Primary key fingerprint: 63CD A1E5 D3FC 22B9 98D2 0DD6 327F 2695 1A01 5CC4 Subkey fingerprint: 16B1 C4EE C0BC 021A C777 F681 B63B 2187 9C34 85B0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 078a89015c05..c53030bba38b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 8 09:38:30 UTC 2016
+# Mon Jun 26 21:17:09 UTC 2017
pkgbase = mkosi
pkgdesc = Build Legacy-Free OS Images
- pkgver = 1
- pkgrel = 2
+ pkgver = 2
+ pkgrel = 1
url = https://github.com/systemd/mkosi
arch = any
license = LGPL2.1
@@ -12,14 +12,18 @@ pkgbase = mkosi
optdepends = dnf: build Fedora images
optdepends = debootstrap: build Debian or Ubuntu images
optdepends = arch-install-scripts: build Arch images
+ optdepends = zypper-git: build openSUSE images
optdepends = gnupg: sign images
optdepends = xz: compress images with xz
optdepends = btrfs-progs: raw_btrfs and subvolume output formats
optdepends = dosfstools: build bootable images
+ optdepends = squashfs-tools: raw_squashfs output format
optdepends = tar: tar output format
+ optdepends = cryptsetup: add dm-verity partitions
optdepends = edk2-ovmf: run bootable images in QEMU
- source = https://github.com/systemd/mkosi/archive/v1.tar.gz
- sha256sums = 83712a72d59435ace5e6a06392c3c81da78572ba1d33f07adc583cead663a03a
+ optdepends = sbsigntools: sign EFI binaries for UEFI SecureBoot
+ source = https://github.com/systemd/mkosi/archive/v2.tar.gz
+ sha256sums = 1b1df95a95cd02ed4d2473d7be147da0829e24b5f84cea91995d76dab2f90de6
pkgname = mkosi
diff --git a/PKGBUILD b/PKGBUILD
index 46a7ac03ece4..705723e80e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Dave Reisner <dreisner@archlinux.org>
pkgname=mkosi
-pkgver=1
-pkgrel=2
+pkgver=2
+pkgrel=1
pkgdesc='Build Legacy-Free OS Images'
arch=('any')
url='https://github.com/systemd/mkosi'
@@ -13,16 +13,25 @@ makedepends=('python-setuptools')
optdepends=('dnf: build Fedora images'
'debootstrap: build Debian or Ubuntu images'
'arch-install-scripts: build Arch images'
+ 'zypper-git: build openSUSE images'
'gnupg: sign images'
'xz: compress images with xz'
'btrfs-progs: raw_btrfs and subvolume output formats'
'dosfstools: build bootable images'
+ 'squashfs-tools: raw_squashfs output format'
'tar: tar output format'
- 'edk2-ovmf: run bootable images in QEMU')
+ 'cryptsetup: add dm-verity partitions'
+ 'edk2-ovmf: run bootable images in QEMU'
+ 'sbsigntools: sign EFI binaries for UEFI SecureBoot')
source=("https://github.com/systemd/mkosi/archive/v$pkgver.tar.gz")
-sha256sums=('83712a72d59435ace5e6a06392c3c81da78572ba1d33f07adc583cead663a03a')
+sha256sums=('1b1df95a95cd02ed4d2473d7be147da0829e24b5f84cea91995d76dab2f90de6')
package() {
cd "mkosi-$pkgver"
+
+ # temporarily fix package version, forgotten in v2 release (remove for next release!)
+ sed -i '/__version__/ s/1/2/' mkosi
+ sed -i '/version/ s/1/2/' setup.py
+
python setup.py install --root="$pkgdir"
}