summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2016-11-07 23:01:31 +0100
committerLucas Werkmeister2016-11-07 23:01:31 +0100
commit8c5a8eb4441b556f36cdb17e07239f3523104390 (patch)
tree39208088c4220937cd826a388cfce7fb43838476
downloadaur-8c5a8eb4441b556f36cdb17e07239f3523104390.tar.gz
Initial commit
Based on Dave Reisner’s mkosi-git package; changes: - Make myself maintainer and change Dave Reisner to contributor in the comments at the top of the package. - Change the package version to the proper release version. - Change the license to LGPL2.1, as indicated by the LICENSE file and the license information in the setup.py script. I have no idea where the GPL in the original PKGBUILD came from; the initial commit of the mkosi-git package repository was about 18 hours after the LICENSE file was added to the mkosi repository in systemd/mkosi@ed122ae. - Remove provides and conflicts directives, which belong only on the -git package. - Add all the dependencies listed in the README.md as optdepends, with explanation. (As far as I can tell, none of them are required, though you will need at least one of dnf, debootstrap, or arch-install-scripts to build any images.) - Change the source to the GitHub release tarball instead of a git URL, and add a SHA2-256 checksum. - Remove the pkgver function. - Generally use single quotes instead of double quotes where possible. - Update the build function to change to the correct directory. I have verified that GitHub’s tarball contains the same tree as the v1 tag in my clone: $ rm -f v1.tar.gz $ wget -q https://github.com/systemd/mkosi/archive/v1.tar.gz $ gunzip < v1.tar.gz | sha256sum 1449e1f6e1ac063311b4650a61cf10d7a0c59a2608f15d8b9a6cdc496b45bfba - $ git archive v1 --prefix=mkosi-1/ | sha256sum 1449e1f6e1ac063311b4650a61cf10d7a0c59a2608f15d8b9a6cdc496b45bfba $ sha256sum v1.tar.gz # this is the sha256sum in the PKGBUILD file 83712a72d59435ace5e6a06392c3c81da78572ba1d33f07adc583cead663a03a v1.tar.gz I have also verified that the v1 tag in my clone was signed (validly) by the same key (5C251B5FC54EB2F80F407AAAC54CA336CFEB557E) that also signed the v230 tag in my clone of the systemd repository. Since I do not have any web-of-trust connection to Zbigniew Jędrzejewski-Szmek, that will have to do.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cfb4be81b1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Nov 7 17:15:12 UTC 2016
+pkgbase = mkosi
+ pkgdesc = Build Legacy-Free OS Images
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/systemd/mkosi
+ arch = any
+ license = LGPL2.1
+ makedepends = python-setuptools
+ depends = python
+ optdepends = dnf: build Fedora images
+ optdepends = debootstrap: build Debian or Ubuntu images
+ optdepends = arch-install-scripts: build Arch images
+ optdepends = xz: compress images with xz
+ optdepends = btrfs-progs: raw_btrfs and subvolume output formats
+ optdepends = dosfstools: build bootable images
+ optdepends = edk2-ovmf: run bootable images in QEMU
+ source = https://github.com/systemd/mkosi/archive/v1.tar.gz
+ sha256sums = 83712a72d59435ace5e6a06392c3c81da78572ba1d33f07adc583cead663a03a
+
+pkgname = mkosi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f56863ae29a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lucas Werkmeister <mail@lucaswerkmeister.de>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+
+pkgname=mkosi
+pkgver=1
+pkgrel=1
+pkgdesc='Build Legacy-Free OS Images'
+arch=('any')
+url='https://github.com/systemd/mkosi'
+license=('LGPL2.1')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=('dnf: build Fedora images'
+ 'debootstrap: build Debian or Ubuntu images'
+ 'arch-install-scripts: build Arch images'
+ 'xz: compress images with xz'
+ 'btrfs-progs: raw_btrfs and subvolume output formats'
+ 'dosfstools: build bootable images'
+ 'edk2-ovmf: run bootable images in QEMU')
+source=("https://github.com/systemd/mkosi/archive/v$pkgver.tar.gz")
+sha256sums=('83712a72d59435ace5e6a06392c3c81da78572ba1d33f07adc583cead663a03a')
+
+package() {
+ cd "mkosi-$pkgver"
+ python setup.py install --root="$pkgdir"
+}