summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Werkmeister2017-06-29 00:26:24 +0200
committerLucas Werkmeister2017-06-29 00:26:24 +0200
commitddb064a47e91fbf1fb82c532e55169d2c603d590 (patch)
tree163039431f839e46ec4ceea6725626c85d3f28d2
parent3222effea7b27fba7bbb1dfc1307c9fc6d23a33a (diff)
downloadaur-ddb064a47e91fbf1fb82c532e55169d2c603d590.tar.gz
Update for mkosi v3
This removes the workaround for the forgotten version number bump, since v3 has the correct version number everywhere. I have verified that GitHub’s tarball contains the same tree as the v3 tag in my clone: $ rm -f v3.tar.gz $ wget -q https://github.com/systemd/mkosi/archive/v3.tar.gz $ gunzip < v3.tar.gz | sha256sum 84e4da79c1cd734c67f64f3e02fa42d32968fc592bf8b942d6ffcaa3bdc211a3 - $ git archive v3 --prefix=mkosi-3/ | sha256sum 84e4da79c1cd734c67f64f3e02fa42d32968fc592bf8b942d6ffcaa3bdc211a3 - $ sha256sum v3.tar.gz # this is the sha256sum in the PKGBUILD file 3bb606f16a26e08ce071e673cb935e62cecb3559db6b41c620f240666d7c5734 v3.tar.gz I have also verified that the v3 tag in my clone was signed (validly) by the same key [1] that also signed the v232 tag in my clone of the systemd repository. Since I do not have any web-of-trust connection to Lennart Poettering, that will have to do. [1]: Primary key fingerprint: 63CD A1E5 D3FC 22B9 98D2 0DD6 327F 2695 1A01 5CC4 Subkey fingerprint: 16B1 C4EE C0BC 021A C777 F681 B63B 2187 9C34 85B0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c53030bba38b..2dc3070bbd91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jun 26 21:17:09 UTC 2017
+# Wed Jun 28 22:23:35 UTC 2017
pkgbase = mkosi
pkgdesc = Build Legacy-Free OS Images
- pkgver = 2
+ pkgver = 3
pkgrel = 1
url = https://github.com/systemd/mkosi
arch = any
@@ -22,8 +22,8 @@ pkgbase = mkosi
optdepends = cryptsetup: add dm-verity partitions
optdepends = edk2-ovmf: run bootable images in QEMU
optdepends = sbsigntools: sign EFI binaries for UEFI SecureBoot
- source = https://github.com/systemd/mkosi/archive/v2.tar.gz
- sha256sums = 1b1df95a95cd02ed4d2473d7be147da0829e24b5f84cea91995d76dab2f90de6
+ source = https://github.com/systemd/mkosi/archive/v3.tar.gz
+ sha256sums = 3bb606f16a26e08ce071e673cb935e62cecb3559db6b41c620f240666d7c5734
pkgname = mkosi
diff --git a/PKGBUILD b/PKGBUILD
index 705723e80e46..cfb8cc6c9597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dave Reisner <dreisner@archlinux.org>
pkgname=mkosi
-pkgver=2
+pkgver=3
pkgrel=1
pkgdesc='Build Legacy-Free OS Images'
arch=('any')
@@ -24,14 +24,9 @@ optdepends=('dnf: build Fedora images'
'edk2-ovmf: run bootable images in QEMU'
'sbsigntools: sign EFI binaries for UEFI SecureBoot')
source=("https://github.com/systemd/mkosi/archive/v$pkgver.tar.gz")
-sha256sums=('1b1df95a95cd02ed4d2473d7be147da0829e24b5f84cea91995d76dab2f90de6')
+sha256sums=('3bb606f16a26e08ce071e673cb935e62cecb3559db6b41c620f240666d7c5734')
package() {
cd "mkosi-$pkgver"
-
- # temporarily fix package version, forgotten in v2 release (remove for next release!)
- sed -i '/__version__/ s/1/2/' mkosi
- sed -i '/version/ s/1/2/' setup.py
-
python setup.py install --root="$pkgdir"
}